View Single Post
  #16  
Old 24th March 2010, 05:16
djmixx07 djmixx07 is offline
Junior Member
 
Join Date: Mar 2010
Posts: 29
Thanks: 1
Thanked 0 Times in 0 Posts
Default Almost done..

Thanks falko,
You're right, that might have been the problem when I uninstalled Postfix; that there are still some Postfix processes running that's why I can't do telnet. Because yesterday I realized that and tried to do a clean uninstall using
Code:
aptitude remove postfix* --purge
which I saw when I was doing some research about the problem with telnet or port 25 being already used.

Doing that suddenly made everything ok with my new installation of postfix. But the next problem was POP3 was offline in ISPConfig and pop3/imap was also missing in "nmap localhost". Found a similar problem in one of your archived forums; and so I reinstalled my Courier using
Code:
apt-get install courier-authdaemon courier-base courier-imap courier-imap-ssl courier-pop courier-pop-ssl courier-ssl gamin libgamin0 libglib2.0-0
which I found here: http://www.howtoforge.com/perfect-se...-ispconfig2-p4

Everything went ok after that with POP3 and IMAP showing now in my nmap localhost, and POP3 now showing online status in ISPConfig. But here's a new issue that suddenly came up..I ran some test emails using webmail (Roundcube) and Thunderbird. I was able to successfully send out emails but when I reply or send email FROM outside domains like Gmail and Yahoo -- it bounces back. Check the mail log and it shows that it's rejecting/refusing connections from outside the server. Here's the error:
Code:
NOQUEUE: reject: RCPT from mail-pv0-f171.google.com[x.x.x.x]: 554 5.7.1 <emailname@domainname.com>: Relay access denied; from=<djdelossantos@gmail.com> to=<emailname@domainname.com> proto=ESMTP helo=<mail-pv0-f171.google.com>
It also shows this:
Code:
mail postfix/smtpd[20597]: warning: unknown[x.x.x.x]: SASL LOGIN authentication failed: authentication failure
I don't know what next to do, but I'm also doing my research. Thanks Falko for the help. Hope we solve this once and for all.

BTW, here's my postconf -n:
Code:
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
inet_interfaces = all
inet_protocols = all
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
mydestination = sample1.domainname.com, localhost.domainname.com, localhost.localdomain, localhost
myhostname = sample1.domainname.com
mynetworks = 127.0.0.0/8, 124.x.x.0/29
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
relayhost = 
smtp_tls_note_starttls_offer = yes
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = 
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
Reply With Quote