View Single Post
  #1  
Old 15th March 2010, 00:22
tristanlee85 tristanlee85 is offline
Senior Member
 
Join Date: Apr 2006
Posts: 199
Thanks: 3
Thanked 2 Times in 2 Posts
Default MyDNS fails to start

I've noticed in the ISPConfig 3 monitor it shows MyDNS as being off-line. Upon trying to start the service, I get this:
Code:
[root@server1 ~]# /etc/init.d/mydns restart
Stopping mydns:                                            [FAILED]
Starting mydns: mydns[2085]: Error connecting to MySQL server at localhost: Access denied for user 'username'@'localhost' (using password: YES) (errno=0)
                                                           [FAILED]
Here is my start-up config:
Code:
[root@server1 ~]# chkconfig --list | grep mydns
mydns          	0:off	1:off	2:on	3:on	4:off	5:on	6:off
I recall in the documentation to set this up that the password would be set during the ISPConfig installation. I ran update.php to re-configure everything, ensuring I didn't leave anything incorrect. Still, the service won't start.

Editing /etc/mydns.conf I see the values are default, so I change them:
Code:
##
##  /etc/mydns.conf
##  Fri Sep 21 21:44:51 2007
##  For more information, see mydns.conf(5).
##


                                # DATABASE INFORMATION

db-host = localhost             # SQL server hostname
db-user = root                  # SQL server username
db-password = XXXXX    # SQL server password
database = dbispconfig                  # MyDNS database name
Now it connects, however, that database doesn't seem to contain the correct tables needed for MyDNS.

Did I miss something?
__________________
ColdFusion Coding, Blog, and Forum
www.cfcoding.com
Reply With Quote
Sponsored Links