View Single Post
  #5  
Old 5th March 2010, 18:53
unclecameron unclecameron is offline
Senior Member
 
Join Date: Apr 2006
Posts: 115
Thanks: 2
Thanked 8 Times in 7 Posts
Default

Since VirtualBox still needs a vnc server, I decided to just work on KVM again, in the meantime I got vncviewer to run a remote box after installing (on server)
Code:
apt-get install tightvncserver xtightvncviewer
vncserver :2 -geometry 1024x768 -depth 16 -pixelformat rgb565
now, after attempting to kill all kvm vm's from the original attempt (before trying VirtualBox) and then trying to install a new one with my :2 display selected, like this:
Code:
virt-install --connect qemu:///system -n sq1 -r 1024 --vcpus=8 \
 -f /home/vm/sq1.qcow5 -s 50 \
 -c /path/to/debian-testing-amd64-CD-1.iso \
 -vnc :2 --noautoconsole --os-type linux --os-variant debianSqueeze \
 --accelerate --network=bridge:br0 --hvm
I get
Code:
ERROR    Guest name 'c' is already in use.
Why do I get this, I'm not specifying guest 'c'? When I enter virsh and run
Code:
virsh # list --all
 Id Name                 State
----------------------------------
  - c                    shut off
  - vm10                 shut off
virsh # destroy c
error: Failed to destroy domain c
error: Requested operation is not valid: domain is not running
virsh # domstate c
shut off
virsh # dominfo c
Id:             -
Name:           c
UUID:           b341252f-46f2-ff62-ef38-71ef2d441cf0
OS Type:        hvm
State:          shut off
CPU(s):         8
Max memory:     1048576 kB
Used memory:    1048576 kB
Autostart:      disable
Security model: qemuDAC
Security DOI:
how do I remove that guest and why can't I create a new one with the above virt-install command? I tried to start 'c' vm and then looked at it, here's what I have:
Code:
ps aux | grep virt
root      1932  0.0  0.0 245148  8452 ?        Sl   08:33   0:00 /usr/sbin/libvirtd -d
106       2449  0.1  0.0 1732084 11884 ?       S    09:27   0:02 /usr/bin/qemu-system-x86_64 -S -M pc-0.11 -m 1024 -smp 8 -name c -uuid b341252f-46f2-ff62-ef38-71ef2d441cf0 -nographic -monitor unix:/var/lib/libvirt/qemu/c.monitor,server,nowait -boot c -drive file=/home/vm/vm11.qcow3,if=ide,bus=0,unit=0,format=raw -drive if=ide,media=cdrom,bus=1,unit=0 -net nic,macaddr=52:54:00:37:4f:e1,vlan=0,name=net0 -net tap,fd=46,vlan=0,name=hostnet0 -serial pty -parallel none -usb -usbdevice tablet -vga none -balloon virtio
but it's not connected to a display so I can't view it on a remote machine, and even if I
Code:
kill 2449
I still get the same error when trying to create a new hostname. I think the install is hung, I just can't figure out how to unhang it
Reply With Quote