View Single Post
  #1  
Old 2nd March 2010, 17:25
barney.parker barney.parker is offline
Junior Member
 
Join Date: Jun 2007
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help! Broken Exim4

Hi,

I have been asked to fix an unstable server, and am having some big issues with exim4!

It seems that the local IT guy in his wisdom decided to apt-get remove exim4.

To compound the problem he then manually deleted various folders named exim4, and also the /etc/init.d/exim4 file.

After many attempts to restore the situation i have managed to get exim to reinstall, but still don't appear to have the /etc/init.d/exim4 file, so i can't actually start exim4!

To fix initially i used aptitude purge to remove all the components of exim4. I then tried to apt-get install exim4 but got loads of errors, so in the end had to apt-get install exim4-daemon-light, then apt-get install exim4.

this then kicked off the dpkg-reconfigure exim4-config as expected.

As far as i can see, the whole thing seems to be there, but with the init.d file missing i am pretty much stuck!!!

Does anyone have any ideas how i can either A) purge exim4 so completely it was like it was never there in the first place, or B) fix the missing file(s?).

Alternatively can anyone suggest an MTA that can be set up to send via a smart-host and will be really simple to set up? (i'm not too well clued up on mail servers!) It only needs to be able to make the PHP function "mail" work correctly sending to external email addresses...

Thanks in advance...
Reply With Quote
Sponsored Links