View Single Post
  #5  
Old 2nd March 2010, 09:23
ethanlifka ethanlifka is offline
Junior Member
 
Join Date: Aug 2008
Posts: 29
Thanks: 0
Thanked 6 Times in 4 Posts
Default

SOLVED!

Got the Errors again after I re-uploaded "php-fcgi-starter.master" in the "/usr/local/ispconfig/server/conf" directory.

It seems I can't re-upload these master files with File-Zilla.
I tried in Binary as will, but still get the errors.

FYI, if you change these files you need to save the site you are working on and logout and log back in through ISPC3 for the changes to take affect.

Any chance to have a "Update Sites" button in the Admin.

I did this many times and still got the errors.

I had to revert to a back-up I created using Shell.

Then no more errors.

?
Why wont this file work when transfered though FTP?
?

Anyways I got it working and I created my own php.ini.master file to use for custom php.ini files.
it gets created each time I create a Fast-CGI site.
I made changes to ""/usr/local/ispconfig/server/plugins-enabled/apache2_plugin.inc.php"
It adds functions in "disable_functions", changes the "upload_tmp_dir" to the sites tmp folder and the session.save_path.

It would be nice if there was a "Use Custom PHP.ini File" checkbox when creating a website that would do this automaticly. Even be able to edit it with a Wysiwyg Editor.

Thanks

Last edited by ethanlifka; 2nd March 2010 at 09:38. Reason: solved
Reply With Quote