View Single Post
  #1  
Old 25th February 2010, 22:21
amccloud amccloud is offline
Junior Member
 
Join Date: Jan 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Pure-FTPd allowing connections to everyone but me...

All of a sudden everyone but me can connect to server. I've tried several different machines in my home. Windows 7 with the built-in FTP client and SmartFTP. I've also tried OSX with the built-in and Cyberduck. All of the clients suddenly disconnect.

Cyberduck's error messages:
Connection failed
Unexpected null reply received.

OSX Built-in error messages:
Connected to [server]
421 Service not available, remote server has closed connection.

I don't have the Windows error messages but they were basically the same.

I've had others outside of my network successfully connect to the same server with the same username and password combination. I've even changed my local networks external ip address to make sure my ip was not blacklisted by some firewall. The server is a Reackspace Ubuntu instance and has no firewall that I am aware of installed or active. We're using mysql for auth but that seems to be working correctly since others can auth, and upload with the accounts in the database. If I use ftplive.com I can also connect.

Also, can someone shed some light on how I can prevent idle timeouts when uploading files that are > 100mb?

Any help is much appreciated!


Thanks,
Andrew
Reply With Quote
Sponsored Links