View Single Post
Old 4th September 2005, 06:00
felipegeek felipegeek is offline
Junior Member
Join Date: Aug 2005
Location: Miami, FL
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Notes for CentOS 4.1 install

Hello to all,

I have just started using ISPConfig and first tried a Debian Sarge install following Falko's Perfect Setup docs. It worked great! I figured I would give it a shot on CentOS 4.1 since I had an interest in running other software that was qualified for RHEL4. I found out that CentOS was not currently supported but if somebody forwarded information on how to get it to work that it would be considered useful. So here I go. Please keep in mind that this install information has NOT been followed up with extensive testing of ISPConfig afterwards so YMMV.

CentOS 4.1 Perfect Setup install mods from Fedora 4 notes. Follow the Fedora 4 notes if its not mentioned in here.

After installing the base OS as described in the Perfect Setup doc and it boots.

--import GPG key for Yum/RPM
rpm --import

--Update Centos--
yum update
Yes <-- to install updates

--remove software
yum remove ppp
Yes <-- will remove pppoe and wvdial

yum remove portmap
Yes <-- will remove NFS and ypbind services as well

yum remove pcmcia-cs
Yes <--

--install some software, everything else in the fedora doc is installed by default and 'apt' can be installed via yum direct from Centos repo --
yum install lynx apt

--Add Dag Wieers RPM repository for APT--
vi /etc/apt/sources.list.d/dag.list
### Dag RPM Repository for Red Hat Enterprise Linux
rpm redhat/el4/en/i386 dag

Save then run..
apt-get update

--ncftp as described for fedora doc is not in CentOS repo. Can be installed with instructions below. Info obtained from VHCS website.--

tar xvfz ncftp-3.1.9-linux-x86-export.tar.gz
cd ncftp-3.1.9
make install

bind-chroot is already installed, do everything else.

--MySQL 4.1--
mysql and mysql-devel already installed.

yum install mysql-server

chkconfig --levels 235 mysqld on
/etc/init.d/mysqld start

--These packages are used by some 3rd party webapps that I might use so I figured to get them installed now.--
apt-get install libmcrypt libmcrypt-devel expect libxslt-devel libjpeg-devel libpng-devel freetype-devel libc-client-devel php-snmp net-snmp-devel httpd-devel

--Postfix With SMTP-AUTH And TLS--
cyrus apps are already installed, imap as named in the Fedora doc does not exist in CentOS repo. I believe it is referenced in 'cyrus-imapd'

apt-get install cyrus-imapd cyrus-imapd-devel postfix

Continue as instructed for FC4...

(I could not find any full set of RPMs for Courier Imap and did not have the time or inclination to make my own though the courier website does explain the whole process.)

-- Apache --
Several of the packages mentioned in the FC4 doc already exist in the CentOS install.

apt-get install php-devel php-gd php-imap php-mysql php-odbc php-xmlrpc ImageMagick

editing /etc/httpd/conf.d/php.conf, there is no AddHandler only the AddType which I commented out.

Continue as FC4...

CentOS repo does not have proftpd. It will come out of the Dag Wieers repo with apt-get.

apt-get remove vsftpd
apt-get install proftpd
chkconfig --levels 235 proftpd on
/etc/init.d/proftpd start

Is already installed as part of CentOS.

--Synchronize time clock--
I used 'ntpdate' instead of rdate which I could not get to grab the time. You could configure ntpd to grab the time as a service or use the cron job as described in the FC4 Perfect setup doc as shown below.

ntpdate (or whatever county code or is closest to you.)

vi /var/spool/cron/root
# update time with ntp server
0 3,9,15,21 * * * /usr/sbin/ntpdate | logger -t NTP

Continue as FC4...

--ISPConfig Installation--
To install ISPConfig create a file /etc/fedora-release with the following content:

'Fedora Core release 4' (without quotes)

This will allow ISPConfig to think its installing on FC4 and let the installer start. You should probably remove the /etc/fedora-release file after you are done so that other software does not get confused if it finds that file before the redhat-release file.

-zlib issue-
The zlib with CentOS is version 1.2.1. You will need to download and compile zlib 1.2.3 as follows. Do not try to uninstall the CentOS rpms. There are many dependencies that would be uninstalled with them and would pretty much trash your OS install. I don't know if the direct installation of zlib 1.2.3 will break anything else.

cd /root
tar xvfz zlib-1.2.3.tar.gz
cd zlib-1.2.3
make test
make install

Run ./setup as usual. You may want to tee the output to a file for diagnostic reasons in case something goes wacky. './setup | tee ispconfig.tee' would be a good start.

I hope this information proves useful to someone and that they might perform more extensive testing of ISPConfig after its setup to see if its really working properly. I am going back to the Debian Sarge install on the second machine.

Regards to the ISPConfig team for a nifty product and to Falko for the great Perfect Setup docs!

I attached the install console output that I teed to a file in case it has any relevent messages for predicting trouble somebody might recognize.


Last edited by felipegeek; 4th September 2005 at 06:19.
Reply With Quote
Sponsored Links