View Single Post
  #1  
Old 22nd February 2010, 09:34
ethanlifka ethanlifka is offline
Junior Member
 
Join Date: Aug 2008
Posts: 29
Thanks: 0
Thanked 6 Times in 4 Posts
Default FastCGI and SuExec Error

I was just about done configuring my new ISPC3 Server.
Then PHP stops working.

My Server: CentOS 5.4 32bit Perfect Setup.
I am using FastCGI with SuExec.
I configured FastCGI to use custom php.ini files.
Installed Mod_Security

Everything Working Great!
Then I noticed that php move_uploaded_files() was setting files to 600 instead of 644. I then added umask 133 to .php-fcgi-starter and it worked. Then I made changes to php-fcgi-starter.master.

No More PHP

Instead I get a 500 Internal Server Error

I reverted php-fcgi-starter.master back to its original, but it didn't do anything.

html still works fine, but its just php.
a simple php file:
Code:
<?php
echo "Hello";
?>
Here are some errors
error_log:
"suexec failure: could not open log file"
"fopen: Permission denied"
"exit communication error terminated by calling exit() return code 1"

I am not sure what file it is refering to.

/var/www/site.com/log/error.log:
file does not exist: /var/www/error/500.html
[error] Premature end of script headers:

I spent about 5 hours with NO success.

I removed mod_security from my httpd.conf, but still nothing.
restarted httpd
rebooted server

Still nothing.

I found a few suggestions and one was to add:
AddType application/x-httpd-phpcgi .php
Action application/x-httpd-phpcgi /cgi-bin/php.cgi
to my .htaccess file, but when I do that I get a 403 Forbidden Error even if I set my .php file to 777.

Then I completely removed my site from ISPC server and re-installed it and still get a 500 Internal Server Error.

Any help would be great.

Thanks
Reply With Quote
Sponsored Links