View Single Post
  #18  
Old 3rd September 2005, 18:28
palkat palkat is offline
Member
 
Join Date: Aug 2005
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
a) In a NAT Enviromet your server knows only his "private" IP Address.

b) Please try this solution with socket bind tight:

http://www.howtoforge.com/forums/sho...p?t=120&page=2
Thanks Till,

I did the socketbindtight - no change

Following the url you gave above i read through and even used the recommended proftpd.conf file instead of the one i created following the "The Perfect Setup -Suse 9.3" instructions. Interesting thing...when i use the PROFTPD.CONF that was posted at http://www.howtoforge.com/forums/sho...p?t=120&page=2 i get the following FTP error on my ftp clients:

----------------
STATUS:> Getting listing ""...
STATUS:> Connecting to FTP server 24.117.228.198:21 (ip = 24.117.228.198)...
ERROR:> The remote host actively refused the attempt to connect to it.
1) Verify that the destination server name or IP address is correct
2) Verify that the connection port number is correct (under Site Settings | Type tab).
3) The remote server may be temporarily or permanently inaccessible (try again later).
4) Verify that you have chosen the right protocol (SSH2, SSL, FTP, etc.) and have setup all required options for that protocol.
5) Verify that the destination IP address and port numbers are correct.
6) The remote server may be refusing multiple connections from the same client. Try using only one connection thread when connecting to this particular server (Site Settings | Options).
7) Try pinging the address.
8) If you are using a router, verify the router is up and running (check by pinging it and then ping an address outside of the router).
9) Do a traceroute to the destination to verify all routers along the connection path are operational.
10) Verify that your subnet mask is setup properly.
11) Verify that your local software or hardware firewall is not blocking outbound connections originating from CuteFTP.
12) Verify that your anti-virus software is not at fault (try disabling it).
------------------

I did note that the url above you gave me to follow the indavidual with the problem notes that his problems started after reinstalling ispconfig..that sticks with me because i too had to reinstall ispconfig to get HTTPS corrected a few days back and never tried ftp till after i reinstalled ispconfig and got HTTPS working.

So i am begining to wonder would just taking the linux box and starting completely from scratch with reinstalling Suse per above instructions and then ISPConfig help?

Thanks guys for continuing to help me with this...im lost but i think beging to understand..will feel good once i can ftp though.
Reply With Quote