View Single Post
  #5  
Old 10th February 2010, 11:48
weezul weezul is offline
Member
 
Join Date: Jul 2008
Posts: 43
Thanks: 3
Thanked 3 Times in 2 Posts
Default

heres what i did:

goto ispconfig uncheck ssl and delete the certificates... click save..
now wait a few minutes or just run the cron urself.

now edit ispconfig settings:


Code:
# vi /usr/local/ispconfig/server/plugins-available/apache2_plugin.inc.php
goto line 140 and change 1024 to 2048 or 4096.

run the cron again, u should see ispconfig generate new keys.

at this step i reloaded apache..

go back into ispconfig, click create certificate and enable ssl.

run the cron, u should see ispconfig creating the keys now...

reload apache, relogin in ispconfig.. your certs should be there now.

now u can use your ssl request file and let it sign from whereever u get your certificate.. replace the certificate created by ispconfig with your signed one.

at this step it worked for me.. also i followed another tutorial so i added 2 more files and pasted the following lines into the options / apache directives form.
Code:
SSLCertificateChainFile /var/www/domain.tld/ssl/sub.class1.server.ca.pem
SSLCACertificateFile /var/www/domain.tld/ssl/ca.pem
Reply With Quote