View Single Post
Old 7th February 2010, 16:08
jdkullmann jdkullmann is offline
Junior Member
Join Date: Nov 2006
Location: NYC
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via AIM to jdkullmann Send a message via Skype™ to jdkullmann
Default Post Etch->Lenny upgrade question

I finally got the nerve to upgrade my production server from Etch to Lenny (thanks Falko and others for answering questions here and the howto's).

The upgrade appears to have worked perfectly - I followed the howto and answered keep my config changes.

However, after the upgrade and reboot I ran 'aptitude update' and 'aptitude dist-upgrade' and instead of the expected up-to-date output got this:

server01:~> sudo aptitude dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
The following packages are BROKEN:
libsasl2 libssp0
The following NEW packages will be installed:
db4.6-util{a} libc-client2007b{a} libcompress-raw-zlib-perl{a} liberror-perl{a}
libio-compress-base-perl{a} libio-compress-zlib-perl{a} libio-socket-inet6-perl{a}
libmail-spf-perl{a} libmime-tools-perl{a} libnetaddr-ip-perl{a} libperl5.10{a} libsnmp15{a}
The following packages will be REMOVED:
libarchive-tar-perl{a} php5-json{a}
The following packages will be upgraded:
amavisd-new cpp-4.1 g++-4.1 gcc-4.1 gcc-4.1-base libapache2-mod-php5 libaprutil1 libberkeleydb-perl
libcompress-zlib-perl libconvert-uulib-perl libdbd-mysql-perl libdbi-perl libdigest-sha1-perl
libhtml-parser-perl liblocale-gettext-perl libmime-perl libnet-dns-perl librrds-perl libsasl2-2
libsasl2-dev libsasl2-modules libsasl2-modules-sql libsocket6-perl libstdc++6-4.1-dev
libtext-charwidth-perl libtext-iconv-perl libunix-syslog-perl perl perl-base perl-modules php-pear
php5 php5-cli php5-common php5-curl php5-dev php5-gd php5-imap php5-mcrypt php5-mhash php5-mysql
php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl razor sasl2-bin
The following packages are RECOMMENDED but will NOT be installed:
libsys-syslog-perl re2c spamc
51 packages upgraded, 12 newly installed, 2 to remove and 2 not upgraded.
Need to get 30.7MB of archives. After unpacking 13.8MB will be used.
The following packages have unmet dependencies:
libsasl2: Depends: libsasl2-2 (= 2.1.22.dfsg1-8+etch1) but 2.1.22.dfsg1-23+lenny1 is to be installed.
libssp0: Depends: gcc-4.1-base (= 4.1.1-21) but 4.1.2-25 is to be installed.
The following actions will resolve these dependencies:

Remove the following packages:

Score is 184

Accept this solution? [Y/n/q/?]

I have no idea what to do at this point?

If I just say Y will it remove libsasl2 and libssp0 and remove and install the packages shown properly? Or am I supposed to manually remove those two packages and re-run dist-upgrade.

Finally, why didn't it just do all this during the full upgrade I just did? Did something go wrong or not happen during the full upgrade or is upgrading a two or more part process and that's normal?

Thanks again, as usual, for any help.
Reply With Quote
Sponsored Links