View Single Post
  #4  
Old 7th April 2006, 09:53
Wraithfire Wraithfire is offline
Member
 
Join Date: Mar 2006
Posts: 57
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux
Driver-8.23.7............................................ ..
.................................................. .........
.................................................. .........
.................................................. .........
.................................................. .........
................................................
==================================================
.[31m ATI Technologies Linux Driver Installer/Packager .[0m
==================================================
Generating package: Debian/sarge
/tmp/fglrx /usr/src/fglrx-install
Package build failed!
Package build utility output:
dpkg-buildpackage: source package is fglrx-installer
dpkg-buildpackage: source version is 8.23.7-1
dpkg-buildpackage: source maintainer is ATI Technologies
Inc. <http://www.ati.com/support/driver.html>
dpkg-buildpackage: host architecture is amd64
debian/rules build
dh_testdir
debian/rules binary
dh_testdir
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
# Create the directories to install into
dh_installdirs -pfglrx-driver \
usr/X11R6 \
usr/X11R6/bin \
usr/X11R6/lib \
usr/X11R6/lib/modules \
usr/share/fglrx/diversions
# the amd64 package includes 32bit compatibility libraries
dh_installdirs -pfglrx-driver \
emul/ia32-linux/usr/X11R6/lib \
emul/ia32-linux/usr/X11R6/lib/modules \
etc/X11/Xsession.d
dh_installdirs -pfglrx-driver-dev \
usr/X11R6 \
usr/X11R6/include \
usr/X11R6/lib \
usr/include
dh_installdirs -pfglrx-kernel-src \
usr/src/modules/fglrx \
usr/src/modules/fglrx/debian
dh_installdirs -A -pfglrx-control-qt3 \
usr/X11R6 \
usr/X11R6/bin \
usr/share \
usr/share/applnk \
usr/share/gnome \
usr/share/icons \
usr/share/pixmaps
dh_installdirs -pfglrx-sources \
usr/src
dh_install
dh_install -pfglrx-driver "usr/X11R6/bin/fgl*"
"usr/X11R6/bin" dh_install -pfglrx-driver
"usr/X11R6/bin/aticonfig" "usr/X11R6/bin" # amd64 needs
some library redirection dh_install -pfglrx-driver
"usr/X11R6/lib64/*.so*" "usr/X11R6/lib" dh_install
-pfglrx-driver "usr/X11R6/lib64/modules/*"
"usr/X11R6/lib/modules" dh_install -pfglrx-driver
"usr/X11R6/lib/*.so*" "emul/ia32-linux/usr/X11R6/lib"
dh_install -pfglrx-driver "usr/X11R6/lib/modules/*"
"emul/ia32-linux/usr/X11R6/lib/modules" dh_install
-pfglrx-driver "debian/70fglrx"
"etc/X11/Xsession.d" dh_install -pfglrx-driver-dev
"usr/X11R6/lib64/*.a" "usr/X11R6/lib" dh_install
-pfglrx-driver-dev "usr/X11R6/include/*"
"usr/X11R6/include" dh_install -pfglrx-driver-dev
"usr/include/*" "usr/include" dh_install
-pfglrx-kernel-src \ lib/modules/fglrx/build_mod/*.c
\
lib/modules/fglrx/build_mod/*.h \
lib/modules/fglrx/build_mod/*.sh \
lib/modules/fglrx/build_mod/lib* \
lib/modules/fglrx/build_mod/2.6.x/Makefile \
usr/src/modules/fglrx
dh_install -pfglrx-kernel-src "debian/changelog"
"usr/src/modules/fglrx/debian" dh_install
-pfglrx-kernel-src \
debian/copyright \
debian/compat \
module/rules \
module/control.template \
module/dirs.template \
module/postinst \
usr/src/modules/fglrx/debian
(cd debian/fglrx-kernel-src/usr/src \
&& chown -R root:src modules \
&& tar -c modules | bzip2 > fglrx.tar.bz2 \
&& rm -rf modules)
# install panel files
dh_install -A -pfglrx-control-qt3
"usr/X11R6/bin/fireglcontrolpanel" "usr/X11R6/bin"
dh_install -A -pfglrx-control-qt3 "usr/share/icons/ati.xpm"
"usr/share/icons" dh_install -A -pfglrx-control-qt3
"usr/share/icons/ati.xpm" "usr/share/pixmaps" dh_install -A
-pfglrx-control-qt3
"usr/share/gnome/apps/fireglcontrol.desktop"
"usr/share/gnome/apps" dh_install -A -pfglrx-control-qt3
"usr/share/applnk/fireglcontrol.kdelnk" "usr/share/applnk"
dh_install -pfglrx-sources "usr/src/*" "usr/src"
dh_installdocs
dh_installdocs -pfglrx-driver usr/share/doc/fglrx/*
#dh_installchangelogs
dh_link
dh_strip
dh_compress
dh_makeshlibs
dh_installdeb
LD_PRELOAD= dh_shlibdeps
dpkg-shlibdeps: warning: could not find path for
libfglrx_gamma.so.1 dpkg-shlibdeps: warning: could not find
path for libfglrx_pp.so.1 /usr/bin/ldd: line 1:
/lib/ld-linux.so.2: No such file or directory ldd:
/lib/ld-linux.so.2 exited with unknown exit code (127)
dpkg-shlibdeps: failure: ldd on
`debian/fglrx-driver/emul/ia32-linux/usr/X11R6/lib/modules/
dri/fglrx_dri.so' gave error exit status 1
dh_shlibdeps: command returned error code 256
make: *** [binary] Error 1
/usr/src/fglrx-install
Removing temporary directory: fglrx-install

Ok finally figured out how to post a file using lynx, this
is the error i get using ati's driver installer. I am
running an amd athlon 64 on Debian 3.1 Sarge with kernel
2.6.16.1 I think the problem has to do with this damn
installer supporting only SUSE and redhat, something I
read somewhere about the installer trying to install 32
libraries on my 64 bit OS. Not sure about that really.
Reply With Quote