View Single Post
  #15  
Old 3rd September 2005, 00:08
palkat palkat is offline
Member
 
Join Date: Aug 2005
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
I guess it's an issue with your router's firewall. Maybe it can't cope with FTP (FTP is a firewall nightmare... ). You might try to turn your router's firewall off for a minute and test if you can connect. Then you'll know if your router's firewall causes the problem or not...
Falko,

Tried that same problem still. In my routers firewall (linksys) i have my ftp port forward back to my windows ftp server and all is well but when pointed to the linux box or bypassing firewall still have issue?

A)
while thinking about this if you look at one of my other ftp client logs it shows the IP or the physical ftp server (192.168.1.205) could that be why it is stopping? that ip shows up right at the list command? shouldn't that IP be my external resolved static IP (24.117.228.198) i get from my cable company?

--------[logs]-------------------
Getting listing ""...
STATUS:> Resolving host name ftp.cryptchat.com...
STATUS:> Host name ftp.cryptchat.com resolved: ip = 24.117.228.198.
STATUS:> Connecting to FTP server ftp.cryptchat.com:21 (ip = 24.117.228.198)...
STATUS:> Socket connected. Waiting for welcome message...
220 FTP Server ready.
STATUS:> Connected. Authenticating...
COMMAND:> USER web4_ol
331 Password required for web4_ol.
COMMAND:> PASS *****
230 User web4_ol logged in.
STATUS:> Login successful.
COMMAND:> PWD
257 "/" is current directory.
STATUS:> Home directory: /
COMMAND:> FEAT
211-Features:
MDTM
REST STREAM
SIZE
211 End
STATUS:> This site supports features.
STATUS:> This site supports SIZE.
STATUS:> This site can resume broken downloads.
COMMAND:> REST 0
350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer
COMMAND:> PASV
227 Entering Passive Mode (192,168,1,205,16,88).
COMMAND:> LIST
STATUS:> Connecting FTP data socket 192.168.1.205:4184...
ERROR:> Timeout (60000 ms) occurred on receiving server response.
ERROR:> PASV failed, trying PORT.
--------------------------------------------------------

B)
Also i noticed this WARNING message when restarting proftpd is there any concern here?
=====
Shutting down ProFTPD Server: done
Starting ProFTPD Server: - warning: "ProFTPD" address/port (192.168.1.205:21) already in use by "ProFTPD Default Installation"
done
=====


C)
I came across this thread on the proftpd site, it is the same problem im having but for a totally differant linux build. they talk about tunring off NSCD helping it, i did try to stop the NSCD service but it wont shut off, when i etll the system to it says its off but if i "chkconfig --list" the list show it still running. Anyways they also talk about a differant linux build so don't want to get in too deep until i see what you think. the thread about this is:
http://bugs.proftpd.org/show_bug.cgi?id=2452

--thanks for helping, i'm desperate to resolve this so i can get my clients up thanks for any help!

Last edited by palkat; 3rd September 2005 at 07:45.
Reply With Quote