View Single Post
  #1  
Old 12th January 2010, 12:07
olasamuelson olasamuelson is offline
Junior Member
 
Join Date: Aug 2008
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default webalizer: Error: Can't open log file /var/www/web34/log/web.log (symlink)

Hi all!
Been like this for a while. I simply cant reinstall must fix. To many domains.
Any clue as to why this happens(now, worked before update some time ago)?

Software: 2.2.33 on f11
Everything works but 403 on "stats".

Here is what i have checked:
- which webalizer gives:/usr/bin/webalizer
- i can run /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php
and it gives lines like"webalizer: Error: Can't open log file /var/www/web34/log/web.log (symlink)"

- ssh to machine as root: i can read/open all of the files webalizer complains about.
They are up to date with log entries. So logs are written.
- ls -la /var/www gives 755 on all directories owner: domain admin and group
is webxx. same on /var/www/webxx/log and "stats" directory
- 775 on subdirs below /var/www/webxx. havent changed that since it worked,
- can access log file both via webxx/log/web.log and via /var/www/domain.se/log/web.log

So...
- webalizer exists
- webalizer finds config
- web.log symlink is there
- web.log is looks properly linked
- target log file is readable and not empty
- permissions "look ok". right?

But:
- since files are not found no content to "stats" is written.

On the other hand:
- should i not be able to see "old" stats instead of a 403?
There are older stats with perms 755 owned by domain.se_admin:webxx

Two errors?

1. webalizer not following symlink for some reason
2. stats url not properly set up

More ideas?
Thanks
Reply With Quote
Sponsored Links