View Single Post
  #14  
Old 2nd January 2010, 07:24
computer_freak_8 computer_freak_8 is offline
Junior Member
 
Join Date: Sep 2009
Posts: 18
Thanks: 3
Thanked 5 Times in 5 Posts
Default

I know this thread is old, but I just finished installing Ubuntu 9.10 (Karmic) on Xen as a guest, so I figured I should post what I had to do to get it that way. (Note: I can't boot... yet. Not sure what's wrong, is says "Error: Bootloader isn't executable"; either way, I managed to get past the stumbling block, as detailed below... perhaps this isn't the right way, but at least it did say that it installed, and not that it failed.)

First, I followed this tutorial, using image-based installations. I originally tried to install Ubuntu as a guest, but it was without success (I haven't tried again until just now, since Debian installed nicely). So, I had some "leftover breadcrumbs" to work off of for this attempt. I found this thread when I used Google for help with the "there is no hook directory for us to use" part.

Here's what I have in one of my directories:
Code:
user@hostname:~$ ls -lA /usr/lib/xen-tools/ubuntu.d/
total 68
-rwxr-xr-x 1 root root  774 2008-09-29 18:08 01-disable-daemons
-rwxr-xr-x 1 root root  595 2008-09-29 18:08 05-shadowconfig-on
-rwxr-xr-x 1 root root  482 2008-09-29 18:08 15-disable-hwclock
-rwxr-xr-x 1 root root 1887 2008-09-29 18:08 20-setup-apt
-rwxr-xr-x 1 root root  511 2008-09-29 18:08 25-generate-locale
-rwxr-xr-x 1 root root 1007 2008-09-29 18:08 30-disable-gettys
-rwxr-xr-x 1 root root 3437 2008-09-29 18:08 35-setup-users
-rwxr-xr-x 1 root root 2649 2008-09-29 18:08 40-setup-networking
-rwxr-xr-x 1 root root 2240 2008-09-29 18:08 50-setup-hostname
-rwxr-xr-x 1 root root  813 2008-09-29 18:08 60-copy-host-files
-rwxr-xr-x 1 root root  729 2008-09-29 18:08 65-copy-user-files
-rwxr-xr-x 1 root root  571 2008-09-29 18:08 70-install-ssh
-rwxr-xr-x 1 root root  843 2008-09-29 18:08 75-fixup-securetty
-rwxr-xr-x 1 root root 1811 2008-09-29 18:08 80-install-modules
-rwxr-xr-x 1 root root 2151 2008-09-29 18:08 90-make-fstab
-rwxr-xr-x 1 root root  485 2008-09-29 18:08 99-clean-image
-rwxr-xr-x 1 root root  584 2008-09-29 18:08 99-enable-daemons
user@hostname:~$
I believe I had just copied them over from one of the other folders - I didn't even have the computer in 2008, and that's the timestamp on the files - so they're probably the same ones that got installed along with the Debian stuff, just not quite in the same spot.

Partial "ls -lA /usr/lib/xen-tools/" output:
Code:
lrwxrwxrwx 1 root root   27 2010-01-01 22:06 karmic.d -> /usr/lib/xen-tools/ubuntu.d
.
.
.
drwxr-xr-x 2 root root 4096 2009-10-20 21:54 ubuntu.d
Again, in this next one, I think it's just a copy of the original for one of the other (older - I think "gusty") Ubuntu scripts; partial "ls -lA /usr/share/debootstrap/scripts/" output:
Code:
lrwxrwxrwx 1 root root    6 2010-01-01 22:12 karmic -> ubuntu
-rw-r--r-- 1 root root 5839 2009-10-20 22:00 ubuntu

Here's the final stuff in the shell:

Code:
user@hostname:~$ sudo xen-create-image --hostname=ubuntu-test-machine --role=udev --dhcp --dist=karmic

General Information
--------------------
Hostname       :  ubuntu-test-machine
Distribution   :  karmic
Partitions     :  swap            512Mb (swap)
                  /               5Gb   (ext3)
Image type     :  sparse
Memory size    :  128Mb

Networking Information
----------------------
IP Address     : DHCP [MAC: FF:11:22:33:44:00]
Netmask        : 255.255.255.x
Broadcast      : x.x.x.255
Gateway        : x.x.x.x


Creating partition image: /home/xen/domains/ubuntu-test-machine/swap.img
Done

Creating swap on /home/xen/domains/ubuntu-test-machine/swap.img
Done

Creating partition image: /home/xen/domains/ubuntu-test-machine/disk.img
Done

Creating ext3 filesystem on /home/xen/domains/ubuntu-test-machine/disk.img
Done
Installation method: debootstrap
Done

Running hooks
Done

Role: udev
	File: /etc/xen-tools/role.d/udev
Role script completed.

Creating Xen configuration file
Done
Setting up root password
Enter new UNIX password: 
Retype new UNIX password: 
passwd: password updated successfully
All done


Logfile produced at:
	 /var/log/xen-tools/ubuntu-test-machine.log
user@hostname:~$

Looking back, I think the bootload issue was caused by me commenting out the kernel/initrd lines in the main xen-tools configuration file. I'm not sure, but I'm loopback-mounting, and chroot-installing a kernel, so I'll find out soon. Also, I think the kernel version needed is "2.6.31-16-generic".
Reply With Quote