View Single Post
  #6  
Old 19th December 2009, 22:00
JosBR JosBR is offline
Junior Member
 
Join Date: Dec 2009
Location: The Netherlands
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Default Posting the solution

I sorted out the problems and I am posting the solution to this forum.

Triggering the solution was:
https://help.ubuntu.com/9.10/serverguide/C/index.html
Pick your item in chapters 10,11,12

Problems MySQL:
WARNING: /etc/mysql/my.cnf cannot be read. See README.Debian.gz
Solution:
I copied Debian.cnf which was in /etc/mysql/ to /etc/mysql/my.cnf

/etc/init.d/mysql: line 123: /etc/mysql/debian-start: No such file or directory
I found _etc_mysql_debian-start in /usr/share/mysql-common/internal-use-only
and copied this file to:
/etc/mysql/debian-start

After that MySQL ran without any problem. No error messages at start up of the server anymore.

I guess it is something for the package manager to work improve.

Problems PHP5:

Trigering the solution to these problems was:

Please verify if the files /etc/apache2/mods-enabled/php5.conf and /etc/apache2/mods-enabled/php5.load exist. If they do not exists, you can enable the module using a2enmod command.

in the Ubuntu server guide.

I opened the terminal and did: a2enmode php5 and php5-mysql ( If I remember well)

After that I could read the php.info file. So PHP was activated.

The only thing that still gave problems was configuring the Virtual host(s) in apache. I did a workaround and changed the default in /sites-available file like this:

<VirtualHost *:80>
ServerAdmin jr@peru4u.com

DirectoryIndex index.php index.html

DocumentRoot /home/jos/Sites

<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>

<Directory /home/jos/Sites/p4u-final>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>


I still do not feel comfortable with that, but at least it works.

My best,

Jos B. Rikhof
Originator of http://www.peru4u.com
Reply With Quote