View Single Post
  #8  
Old 19th December 2009, 13:15
bnight bnight is offline
Junior Member
 
Join Date: Dec 2009
Posts: 4
Thanks: 0
Thanked 3 Times in 3 Posts
Default

Hi phor,

I have the same problem as you have and I make some tests about howto disable Amavis on ISPConfig 3.

Here is what you have to do to achieve this:

Edit: /etc/postfix/main.cf

Coment this two lines:

content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings

Looks like this:

#content_filter = amavis:[127.0.0.1]:10024
#receive_override_options = no_address_mappings

Edit: /etc/postfix/master.cf

And comment all lines bellow:

amavis unix - - - - 2 smtp

Looks like this:

#amavis unix - - - - 2 smtp
# -o smtp_data_done_timeout=1200
# -o smtp_send_xforward_command=yes

#127.0.0.1:10025 inet n - - - - smtpd
# -o content_filter=
# -o local_recipient_maps=
# -o relay_recipient_maps=
# -o smtpd_restriction_classes=
# -o smtpd_client_restrictions=
# -o smtpd_helo_restrictions=
# -o smtpd_sender_restrictions=
# -o smtpd_recipient_restrictions=permit_mynetworks,rej ect
# -o mynetworks=127.0.0.0/8
# -o strict_rfc821_envelopes=yes
# -o receive_override_options=no_unknown_recipient_chec ks,no_header_body_checks
# -o smtpd_bind_address=127.0.0.1

Now stop amavis-new and clamd:

/etc/init.d/amavis stop
/etc/init.d/clamav-daemon stop
/etc/init.d/clamav-freshclam stop

Now disable amavis and clamd form starting on system boot:
chkconfig --levels 235 amavis off
chkconfig --levels 235 clamav-daemon off
chkconfig --levels 235 clamav-freshclam off


Now you can restart postfix:

/etc/init.d/postfix restart


And you have working postfix without Amavis and Clamd.

Good Luck.
Reply With Quote