View Single Post
  #1  
Old 14th December 2009, 15:02
vistree vistree is offline
Member
 
Join Date: Aug 2006
Posts: 61
Thanks: 2
Thanked 4 Times in 3 Posts
Default problem with additional mailbox_transport for groupware

Hi, I hope you can help ...

I set up ispconfig 3 - and it is working great!!!
I have just one litte problem I spent now hours to solve: I have to transport mails to an additional service on the server.
OK, in detail:
I have set up a lot of domains and mailboxes.
For one domain, I want to deliver mails not only to the Maildir-folger (/var/vmail/domainx.tld/userX ). Instead I want to sent it also to an extra service on the server. I use a groupware which wants to store all mails inside its own database.
So I tried a lot of modifications for postfix:
All edits are ADDITIONAL to the original ones from isp3
main.cf --> at the end
Code:
mailbox_transport = groupware:
groupware_destination_recipient_limit = 1
master.cf --> at the end
Code:
groupware  unix  -       n       n       -       10       pipe
  flags= user=vmail argv=/usr/bin/groupware-deliverprog ${recipient}
I tried also with ${user} and ${original_recipient}

But I can't even find an log entry in mail.log or the groupwares log. It seems, that postfix does not execute the command??

If I start the groupware-deliverprog from shell, everything works fine.

Any hints for me? Thank you
Reply With Quote
Sponsored Links