View Single Post
  #1  
Old 3rd December 2009, 00:25
lucani lucani is offline
Member
 
Join Date: Nov 2009
Posts: 81
Thanks: 4
Thanked 4 Times in 3 Posts
Exclamation ISPConfig3 MyDNS-ng master axfr zone transfer to bind9 slave

Hello!

It's 3rd day when I'm fighting with zone transfers from MyDNS to bind server. I read hundreds of pages from this forum and from google but it still doesn't work.

Firstly, I set IPs in "allow zone transfers" in DNS tab in ISPConfig,
secondly, I recompile fixed mydns-ng (http://www.howtoforge.com/forums/sho...t=32145&page=2),
next I edit config MyDNS config file (mydns.conf):

Code:
log = LOG_DAEMON        # Facility to use for program output (LOG_*/stdout/stder
pidfile = /var/run/mydns.pid    # Path to PID file
timeout = 120   # Number of seconds after which queries time out
multicpu = 1    # Number of CPUs installed on your system
recursive =                      # Location of recursive resolver
allow-axfr = yes # Should AXFR be enabled?
allow-tcp = no  # Should TCP be enabled? I'm not sure
allow-update = yes       # Should DNS UPDATE be enabled?
ignore-minimum = no     # Ignore minimum TTL for zone?
soa-table = dns_soa     # Name of table containing SOA records
rr-table = dns_rr       # Name of table containing RR data
soa-where = server_id = 1               # Extra WHERE clause for SOA queries
rr-where =  server_id = 1               # Extra WHERE clause for RR queries
use-soa-active = yes # To fix bug 295 where active or inactive status is ignored
use-rr-active = yes# To fix bug 295 where active or inactive status is ignored.
notify-enabled = yes
notify-source xxx.xxx.xxx.xxx
and also bind config :
(named.conf.options):
Code:
options {
        directory "/var/cache/bind";

        allow-transfer {xxx.xxx.xxx.xxx;};
        dnssec-enable yes; // I'm not sure
        auth-nxdomain no;    # conform to RFC1035
        listen-on-v6 { any; };
        request-ixfr no;
};
(named.conf):
Code:
zone "zone1.com" IN {
type slave;
file "/var/cache/bind/zone1.com.conf";
masters { xxx.xxx.xxx.xxx; };
allow-notify { xxx.xxx.xxx.xxx; };
};
With this config it's trying to work, but not at all:

When zone file in /var/cache/bind is deleted, I restart bind and full zone is transfered by axfr to slave server. But then it's freezing. When I change anything on primary server (=generate new serial in SOA) nothing happens. Slave should be notified, but it doesn't. I want also say that in nslookup and dig @xxx.xxx.xxx.xxx axfr zone1.com everything is all right.

Could You help me with this problem?

Last edited by lucani; 3rd December 2009 at 00:30.
Reply With Quote
Sponsored Links