View Single Post
  #1  
Old 10th November 2009, 00:07
mscomputing mscomputing is offline
Junior Member
 
Join Date: Nov 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default email issue for second domain configured ISPConfig3

Hi All,

Just like to say thank you to Falko for a great How To. I setup 'Perfect Server - Ubuntu 9.04 - ISPConfig3' and on the whole everything works well.

I do however have an issue with a second domain i have setup in ISPConfig3.

My first domain is fully funtional both for web access and email however my second domain seems fine for the website but not for recieving email. When sending email to the second domain i keep on getting a permanent DNS Error.

Can anyone please point me in the right direction.

DNS records as follows:
First domain DNS Config
A mail (server ip) 0
A www (server ip) 0
A (domain.tld) (server ip) 0
MX (domain.tld) (mail.domain.tld) 10
NS (domain.tld) (ns1.domain.tld) 0
NS (domain.tld) (ns2.domain.tld) 0

Second Domain DNS Config
A mail (server ip) 0
A www (server ip) 0
A (2nd domain.tld) (server ip) 0
MX (2nd domain.tld) (mail.domain.tld) 10
NS (2nd domain.tld) (ns1.2nd domain.tld) 0
NS (2nd domain.tld) (ns2.2nd domain.tld) 0


Note that for the second domain i used the same mailserver as for the first domain hence my MX record points to the same mail.domain.tld however my domain.tld is different.

Mail works perfectly for the first domain but the second domain does not seem to exist as i get a permanent DNS error when emailling from a external email account to the email account setup for the second domain.tld.

Question 1:
Should i be using the same mail.domain.tld for both domain emails?

Querstion 2:
If not could you please explain how i could configure email for the second domain?

Appreciate you feeback...
Reply With Quote
Sponsored Links