Thread: problems mysql
View Single Post
  #8  
Old 28th March 2006, 12:15
geek.de.nz geek.de.nz is offline
Member
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via ICQ to geek.de.nz Send a message via MSN to geek.de.nz
Default

OK, this is weird. I unchecked the check box for that user, saved, and checked it again, saved, and it works.

Still it might be a very subtle bug in the code, maybe you should check this. But then it isn't that big a problem.

So, to repeat what I did:

1. Create reseller without MySQL and Shell access
2. Create Client under this reseller
3. Create website under this client
4. Create user under this site (without MySQL and without Shell)
5. Modify reseller to have MySQL dbs and Shell access
6. Modify site to have shell and mysql
7. Modify user to have mysql and shell, but shell and actually mysql as well didn't work

Yeah, now that I go through it, how do I access mysql with a user that has shell access (or otherwise)? It doesn't seem to work with
Code:
webx_xxx@www#mysql
or
Code:
webx_xxx@www#mysql -p
(with entering the users password)
?

Also, if I enter mysql with my root user I cannot see any entry in the mysql.user table for webx_xxx or anything. How does this part work, because I didn't see any option in ISPConfig about enabling mysql access for users or similar?
__________________
Always mention at least your distribution/version! You can add it in your signature if you don't want to always type it. ;-)

Distributions:
Ubuntu 5.10 with custom kernel (2.6.16-suspend2),
Debian Sarge 3.1 and Etch

Please submit your ISP or Webhost to (free)
http://www.ihostnz.com
Reply With Quote