View Single Post
  #6  
Old 25th September 2009, 18:13
dowdle dowdle is offline
Junior Member
 
Join Date: Sep 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default More information

Here is my grub.conf stanza that gives me the error:

title OpenVZ RHEL5 Stable (2.6.18-128.2.1.el5.028stab064.7)
root (hd1,0)
kernel /boot/vmlinuz-2.6.18-128.2.1.el5.028stab064.7 ro root=/dev/md0
initrd /boot/initrd-2.6.18-128.2.1.el5.028stab064.7.img

Here's the fdisk -l output

[root@backup1 etc]# fdisk -l

Disk /dev/sda: 73.4 GB, 73407820800 bytes
255 heads, 63 sectors/track, 8924 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 8401 67481001 83 Linux
/dev/sda2 8402 8923 4192965 82 Linux swap / Solaris

Disk /dev/sdb: 73.4 GB, 73407820800 bytes
255 heads, 63 sectors/track, 8924 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 8401 67481001 fd Linux raid autodetect
/dev/sdb2 8402 8923 4192965 fd Linux raid autodetect

Here's the output of /proc/mdstat

[root@backup1 etc]# cat /proc/mdstat
Personalities : [raid1]
md1 : active raid1 sdb2[1]
4192896 blocks [2/1] [_U]

md0 : active raid1 sdb1[1]
67480896 blocks [2/1] [_U]

unused devices: <none>

Here's the contents of /etc/fstab:

[root@backup1 etc]# cat /etc/fstab
/dev/md0 / ext3 defaults,noatime 1 1
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/md1 swap swap defaults 0 0

Here's the contents of /etc/mtab:

[root@backup1 etc]# cat /etc/mtab
/dev/md0 / ext3 rw,noatime 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0

Here's the output of mount:

[root@backup1 etc]# mount
/dev/md0 on / type ext3 (rw,noatime)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)

- - - - -

So at this point it appears the RAID1 with 1 drive is working but I can't seem to boot unless I use the grub stanza that says "root=/dev/sda1".

I'm not wanting to progress with the rest of the HOWTO (to join the /dev/sda1 and /dev/sda2 parts to the RAID1) until I can get this figured out.

Any ideas? If there is any other output I could provide you that would be helpful, please let me know.
Reply With Quote