View Single Post
  #18  
Old 9th September 2009, 11:30
jysse jysse is offline
Member
 
Join Date: Aug 2005
Location: Laihia, Finland
Posts: 31
Thanks: 0
Thanked 3 Times in 1 Post
Default

Here is how I managed to make this work.
Debian Lenny, ISPConfig3

If I understood correct there was an error in Debian's pure-ftpd filter. Correct line in /etc/fail2ban/filter.d/pure-ftpd.conf should be:
failregex = pure-ftpd(?:\[\d+\])?: \(.+?@<HOST>\) \[WARNING\] %(__errmsg)s \[.+\]$

Here is my jail.conf lines for pure-ftpd:

[pure-ftpd]
enabled = true
port = ftp
filter = pure-ftpd
logpath = /var/log/messages
maxretry = 2

Hope this helps !

jysse
Reply With Quote