View Single Post
  #5  
Old 25th March 2006, 16:13
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,044
Thanks: 269
Thanked 154 Times in 133 Posts
Default

Looking at my /var/log/httpd/error_log I also have LOTS of [error] an unknown filter was not added: PHP in it!
It looks like the /etc/httpd/conf/vhost/Vhosts_ispconfig.conf is the problem.

In it there is this
Code:
<Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
This is what I found:

Quote:
Since 4.3.2RC the default Apache 2 sapi is the apache2handler and is no
longer filter based. Therefor you should use
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

and not

<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>

If you do want to use the old filter sapi, you need to use
--with-apxs2filter option.Since 4.3.2RC the default Apache 2 sapi is the apache2handler and is no
longer filter based. Therefor you should use
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

and not

<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>

If you do want to use the old filter sapi, you need to use
--with-apxs2filter option.
I'm not sure if I had this problem with the 'old' ISPconfig.. I'm now using the 2.2.0 version of ISPconfig.

I guess I need to change the

Code:
$go_info["server"]["apache2_php"] = 'both';
to:

Code:
$go_info["server"]["apache2_php"] = 'false';
in the /home/admispconfig/ispconfig/lib/config.inc.php, or can I just disable that line 100% (//) ??

Last edited by edge; 25th March 2006 at 16:26.
Reply With Quote