View Single Post
  #12  
Old 3rd September 2009, 16:22
Keeper Keeper is offline
Member
 
Join Date: Aug 2009
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Not only subdomains but looks like I also have trouble with sending emails. My forums won't send anything out with PHP mail function. Server setup closely follows Debian Lenny 5.0 perfect server guide.

/var/log/mail.err
Quote:
Sep 3 09:52:34 server amavis[8777]: (08777-01) (!!)run_av (ClamAV-clamd) FAILED - unexpected , output="/var/lib/amavis/tmp/amavis-20090903T095234-08777/parts: lstat() failed. ERROR\n"
Sep 3 09:52:34 server amavis[8777]: (08777-01) (!!)ClamAV-clamd av-scanner FAILED: CODE(0x3278108) unexpected , output="/var/lib/amavis/tmp/amavis-20090903T095234-08777/parts: lstat() failed. ERROR\n" at (eval 100) line 527.
Sep 3 09:52:34 server amavis[8777]: (08777-01) (!!)WARN: all primary virus scanners failed, considering backups
Sep 3 09:52:34 server amavis[8777]: (08777-01) (!!)TROUBLE in check_mail: virus_scan FAILED: virus_scan: ALL VIRUS SCANNERS FAILED: ClamAV-clamd av-scanner FAILED: CODE(0x3278108) unexpected , output="/var/lib/amavis/tmp/amavis-20090903T095234-08777/parts: lstat() failed. ERROR\n" at (eval 100) line 527.
Sep 3 09:52:34 server amavis[8777]: (08777-01-2) (!!)TROUBLE in process_request: Can't create file /var/lib/amavis/tmp/amavis-20090903T095234-08777/email.txt: File exists at /usr/sbin/amavisd-new line 5138, <GEN26> line 29.
/var/log/mail.warn
Quote:
Sep 3 09:52:34 server amavis[8777]: (08777-01) (!!)run_av (ClamAV-clamd) FAILED - unexpected , output="/var/lib/amavis/tmp/amavis-20090903T095234-08777/parts: lstat() failed. ERROR\n"
Sep 3 09:52:34 server amavis[8777]: (08777-01) (!!)ClamAV-clamd av-scanner FAILED: CODE(0x3278108) unexpected , output="/var/lib/amavis/tmp/amavis-20090903T095234-08777/parts: lstat() failed. ERROR\n" at (eval 100) line 527.
Sep 3 09:52:34 server amavis[8777]: (08777-01) (!!)WARN: all primary virus scanners failed, considering backups
Sep 3 09:52:34 server amavis[8777]: (08777-01) (!!)TROUBLE in check_mail: virus_scan FAILED: virus_scan: ALL VIRUS SCANNERS FAILED: ClamAV-clamd av-scanner FAILED: CODE(0x3278108) unexpected , output="/var/lib/amavis/tmp/amavis-20090903T095234-08777/parts: lstat() failed. ERROR\n" at (eval 100) line 527.
Sep 3 09:52:34 server amavis[8777]: (08777-01) (!)PRESERVING EVIDENCE in /var/lib/amavis/tmp/amavis-20090903T095234-08777
Sep 3 09:52:34 server amavis[8777]: (08777-01-2) (!!)TROUBLE in process_request: Can't create file /var/lib/amavis/tmp/amavis-20090903T095234-08777/email.txt: File exists at /usr/sbin/amavisd-new line 5138, <GEN26> line 29.
Sep 3 09:52:34 server amavis[8777]: (08777-01-2) (!)Requesting process rundown after fatal error
Sep 3 09:53:27 server postfix/smtpd[8448]: warning: xxx.xx.xx.xx: hostname xxx.xx.xx.xx.pldt.net verification failed: Name or service not known
IP-address censored, but it's not associated with our server or IP. Rest of the mail logs are empty.

I also created email-domain, set it as mail.domain1.com as found in MX DNS record. Then created email mailbox and set it as noreply@mail.hard-light.net. Now when I set my forums to use SMTP with username noreply@mail.hard-light.net and the password I set, it still doesn't send any emails.

Last edited by Keeper; 3rd September 2009 at 16:30.
Reply With Quote