View Single Post
  #6  
Old 28th August 2009, 00:01
kings kings is offline
Member
 
Join Date: Aug 2009
Location: Bulgaria
Posts: 40
Thanks: 4
Thanked 0 Times in 0 Posts
Send a message via Skype™ to kings
Default Re broblem with .htaccess

Quote:
Originally Posted by madmucho View Post
as you want you can change global settings for vhosts to accept .htaccess directives or do it per site in ispconfig system, best practice is dont allow users .htaccess if they dont need it or dont know what that is :-) that is for security reason.

Global directive can be placed in..
Code:
/etc/httpd/conf/httpd.conf
at the end of file

Code:
<Directory /var/www/*/web>
    Options +Includes +FollowSymlinks -Indexes
    AllowOverride All
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
For Joomla that will be enough. But that is not recomended setting...
Special thanks!
When i make this chages in /etc/httpd/conf/httpd.conf result is FULL ZERO.Apache stoped imediately in log file - not eny trace for reason of stop. Falko sayd Quote"Any errors in the web site's error log or the overall Apache error log" end quote
When I put this <Directory /var/www/*/web>
Options +Includes +FollowSymlinks -Indexes
AllowOverride All
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>

in /etc/httpd/vhost/Vhosts_ispconfig.conf
Code:
###################################
#
# ISPConfig vHost Configuration File
# Version 1.0
#
###################################
#
NameVirtualHost 192.168.1.2:80
<VirtualHost 192.168.1.2:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
RewriteRule .* - [F]
</IfModule>
</VirtualHost>

<Directory /var/www/*/web>
Options +Includes +FollowSymlinks -Indexes
AllowOverride All
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>
#
#
######################################
# Vhost: www.example.com:80
######################################
#
#
<VirtualHost 192.168.1.2:80>
and etc code...

IT IS WORK FULL. APACHE DON"T STOP. YOU CAN TO CHANGE htaccess.txt
to .htaccess!

THANK YOU MADMUCHO
Reply With Quote