View Single Post
  #24  
Old 23rd March 2006, 02:26
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

Quote:
Originally Posted by falko
It seems your vsftpd was run by xinetd, so you should have restarted xinetd.

But now that you want to run it with an init script, you should check if /etc/init.d/vsftpd uses the correct config file (I guess it looks for /etc/vsftpd.conf instead of /etc/vsftpd/vsftpd.conf).

You can kill the running vsftpd process with

Code:
kill -9 27830
Ya Hoo! I finally got it up and running!!

It was not running in xinted (I disabled that 2 days ago) and for some reason it never existed in init.

The kill command was the key.
Code:
vsftpd &
was not stoping or restarting the service. After initial use if I changed the config file and run it again it would just return
Code:
500 OOPS: could not bind listening IPv4 socket
because it was already running.

I finally found /usr/share/doc/packages/vsftpd and there was a folder called EXAMPLES. It gives several set-ups with the config files. I used INTERNET_SITE_NOINETD, changed a couple setting to YES and that did it!

I need to figure out why commands (Start, Stop, Restart, nmap) don't seem to be working in my Konsole. Or is that a Gnome thing? I went KDE this time and while I like it better so far there are differences I am still adjusting too.

thanks for the help falco!
Reply With Quote