View Single Post
  #2  
Old 22nd March 2006, 17:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by rbrantley
Regardless of what I change this to(i.e. server.thermalhost.com) certain parts of Ubuntu stop working, if I reboot I get a message stating that it the hostname has an error and gives me a warning that certain parts of the OS may not operate correctly. It then gives me the option to try again or login anyway. Once I choose login anyway, I can't do basic things such as open File Browser, gEdit, Synaptic Package Manager, etc...It seems like the change prevents these from working in its entirety. Not knowing what to do the first time I simply reformatted and skipped the Setting the Hostname section and went through the entire installation, which is working fine it seems. I tried to set the hostname again last night with the same results as before, I ound that after logging back in it acted the very same way and I tried, using terminal, to change it back to localhost. It started working again but I'm unsure of how to go about this.
You must make sure that the hostname you use exists in DNS. If it doesn't, then you should at least add it to /etc/hosts.

Quote:
Originally Posted by rbrantley
2) Also another issue I'm having trouble understanding is with BIND. I have my registrar setup to look at my server for DNS resolution. I also was thinking of using everydns.net as a secondary DNS if possible. However when I check DNS report I receive several fatals. I am unsure exactly how to treat each of these, some of them(i.e. ns0.thermalhost.com; mail.thermalhost.com) need a DNS entry but I am thinking that these would need to be edited in the named.conf directly instead of using ISPConfig. Please check out my DNSReport here .

If I need to submit more information please let me know. Thanks in advance for any advice offered.
thermalhost.com points to a private IP address:

Code:
dig thermalhost.com

; <<>> DiG 9.2.1 <<>> thermalhost.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26538
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;thermalhost.com.               IN      A

;; ANSWER SECTION:
thermalhost.com.        86400   IN      A       192.168.2.2

;; Query time: 371 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Wed Mar 22 17:51:34 2006
;; MSG SIZE  rcvd: 49
You must use public IP addresses because otherwise nobody from outside your network can see your site.

Have a look here: http://www.howtoforge.com/forums/sho...92&postcount=4
and here: http://www.howtoforge.com/traditional_dns_howto
and here: http://en.wikipedia.org/wiki/Domain_name_system to learn more about DNS.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote