View Single Post
  #3  
Old 30th August 2005, 18:03
SidSkiba SidSkiba is offline
Junior Member
 
Join Date: Aug 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Wink Pear

I log in as root and do (forgive me as I am not a Linux expert yet)

pear install HTTP_Request

I get a bash error saying something like unknown or does not exist.

I assumed that to mean that Pear was not installed. My SuSE setup was done as a minimal graphical setup and then followed the Perfect SuSE 9.3 Setup to add the Apache and PHP components.

I do not know where apt gets the package from but according to Pear site the following may be the case:

When using PHP >= 4.3.0, the PEAR Package Manager is already installed unless one has used the ./configure option --without-pear

So I thought I might try adding the Pear installer with:

lynx -source http://go-pear.org/ | php

It did not work. I got an error saying php was unknown or something like that. I realise today that I have PHP 5 so I should have tried:

lynx -source http://go-pear.org/ | php5

That is about where I got to.

I did not try SuSE Yast2 to add pear (did not think to try). I tried apt-get install pear and it failed. But I did not know the exact message to use.

If I use Yast2 will Pear be compatible with PHP5? SuSe comes with PHP4.

I had used the apt-get install for the PHP packages (per the Perfect Setup) and not sure if that should have added Pear?

Any suggestions would be great.
Reply With Quote