View Single Post
  #1  
Old 19th July 2009, 20:46
claudioimai claudioimai is offline
Junior Member
 
Join Date: Jul 2007
Posts: 23
Thanks: 4
Thanked 0 Times in 0 Posts
Question DNS server error: cannot fetch SOA record

Hello.

I have a server with ispconfig2 installed (debian perfect install), and a website with 2 domains pointing to it. One is <mydomain>.com and the other is <mydomain>.com.br

The main domain was <mydomain>.com until last week, when I decided to install a SSL cert on it. For this purpose, I exchanged the 2 domains in the ispconfig's panel, and thought everything would be OK. (on Friday)

Today, my site is down, and someone told me it was down since yesterday.

Checking the dns with checdns.net, I get the following error:

Code:
Tried to fetch SOA record for domain, but DNS server ns1.xxx.com [xxx.xxx.xxx.xxx] returned error code Server Failure
  Tried to fetch SOA record for domain, but DNS server ns2.xxx.com [xxx.xxx.xxx.xxx] returned error code Server Failure
  0 server(s) are alive
  No DNS servers alive, tests stopped
Reading the file /var/lib/named/etc/bind/pri.xxx.com.br, I find:

Code:
$TTL        86400
@       IN      SOA     ns1.yyyy.com. xxxx.xxx.com.br. (
                        2009071902       ; serial, todays date + todays serial #
                        28800              ; refresh, seconds
                        7200              ; retry, seconds
                        300              ; expire, seconds
                        86400 )            ; minimum, seconds
;
                NS      ns1.xxx.com.              ; Inet Address of name server 1
                NS      ns2.xxx.com.              ; Inet Address of name server 2
;

  MX      10 ASPMX.L.GOOGLE.COM.
  MX      20 ALT1.ASPMX.L.GOOGLE.COM.
  MX      30 ALT2.ASPMX.L.GOOGLE.COM.
  MX      40 ASPMX2.GOOGLEMAIL.COM.
  MX      50 ASPMX3.GOOGLEMAIL.COM.
  MX      60 ASPMX4.GOOGLEMAIL.COM.
  MX      70 ASPMX5.GOOGLEMAIL.COM.

ecartgt.com.br.      A        xxx.198.133.14
correios       A       xxx.198.133.14
www       A       xxx.198.133.14
visa       A       189.38.80.70

docs       CNAME  ghs.google.com.
mail       CNAME  ghs.google.com.

mail.ecartgt.com.br.       TXT  "v=spf1 ip4:xxx.198.133.14 include:aspmx.googlemail.com ~all"

;;;; MAKE MANUAL ENTRIES BELOW THIS LINE! ;;;;
Can someone help me with this? I can't seem to find anything wrong here

Thanks!

EDIT: Turned that the problem was in the SPF record I placed due to google Apps. after removing it, the domain has come back to life.

Last edited by claudioimai; 19th July 2009 at 22:28.
Reply With Quote
Sponsored Links