View Single Post
  #1  
Old 16th July 2009, 13:26
psykosen psykosen is offline
Junior Member
 
Join Date: Jul 2009
Location: Denmark
Posts: 26
Thanks: 5
Thanked 5 Times in 4 Posts
Default Nat Gateway ??? help

hey guys

I have a small problem I am about to put a new lan network together in my company! it is intended that the Internet connection goes into my (DHCP, PXE, File and print) server! These works perfect but I can not get internet to work! I have tried forwarding (eth0 => eth1) with iptables and it will not work(for me)

this is what I have tried!!

Quote:
echo 1 > /proc/sys/net/ipv4/ip_forward
then

To delete existing rules from every iptables table, execute the following commands:
Quote:

iptables -F
iptables -t nat -F
iptables -t mangle -F

Quote:
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
iptables -A FORWARD -i eth1 -j ACCEPT
and then i type "iptables -L" i get this output
Quote:
gate1:~# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination
ACCEPT all -- anywhere anywhere

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
should it not show that it forwarded from eth0 => eth1
i'm not a guro in iptables so eny help is welcome
i'm totaly lost there

I have searched online for some days now and can not really find a solutions that works have tried this howto but without result
searched howtoforge for iptables, forwarding etc..
but nothing seem to work(mabe its me )

looked over my log files even trail -f whill the client boots up but now errors there

Regards
Psykosen

oh! i'm running Debian lenny with DHCP, PXE, File and Print server
and it works perfect nothing there
Reply With Quote
Sponsored Links