View Single Post
  #12  
Old 8th July 2009, 01:48
TokyNET TokyNET is offline
Junior Member
 
Join Date: Jun 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the reply, I'm looking at this thread since this is the only one i've found that had a "how-to" to get ssl working on the control panel. I however, have no ssl.conf on /etc/http/conf.d (or under any directory under /etc/http/ )

So, it looks like that is part of my probelm, also like I mentioned before, im not sure where I'm supposed to add the content stated on this how-to about the ispconfig.vhost. I have pasted my vhost file.

I have added the extralines in a bunch of places and it does not work (only 1 at a time though) this is what I get when I have the lines enabled on my conf:

Code:
|root@cornpops|____|Tue Jul 07|____|19:44:50|____| jobs:0/pts:1/users:2/sites-available/ 
# -->/etc/init.d/httpd start
Starting httpd: Syntax error on line 14 of /etc/httpd/conf/sites-enabled/000-ispconfig.vhost:
Invalid command 'SSLEngine', perhaps misspelled or defined by a module not included in the server configuration
                                                           [FAILED]
This is the current state of my ispconfig.vhost:
Code:
Listen 8080
NameVirtualHost *:8080

<VirtualHost _default_:8080>
ServerAdmin webmaster@localhost
  <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    SSLEngine On
    SSLCertificateFile /etc/httpd/ssl/server.crt
    SSLCertificateKeyFile /etc/httpd/ssl/server.key
    <Directory /var/www/ispconfig/>
      Options Indexes FollowSymLinks MultiViews +ExecCGI
      AllowOverride AuthConfig Indexes Limit Options FileInfo
      AddHandler fcgid-script .php
      FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
      Order allow,deny
      Allow from all
    </Directory>
  </IfModule>

  <IfModule mod_php5.c>
    DocumentRoot /usr/local/ispconfig/interface/web/
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
      Options FollowSymLinks
      AllowOverride None
      Order allow,deny
      Allow from all
      php_value magic_quotes_gpc        0
    </Directory>
  </IfModule>
  <IfModule mod_php5.c>
    DocumentRoot /usr/local/ispconfig/interface/web/
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
      Options FollowSymLinks
      AllowOverride None
      Order allow,deny
      Allow from all
      php_value magic_quotes_gpc        0
    </Directory>
  </IfModule>

  # ErrorLog /var/log/apache2/error.log
  # CustomLog /var/log/apache2/access.log combined
  ServerSignature Off

</VirtualHost>

<Directory /var/www/php-cgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<Directory /var/www/php-fcgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>
I will look into creating the ssl.conf file, but that error when I try to start apache when the conf file is edited makes me believe that even once I get the file created, its not going to work.

Last edited by TokyNET; 8th July 2009 at 02:12. Reason: fixing pasted code
Reply With Quote