View Single Post
  #7  
Old 7th July 2009, 21:18
y87 y87 is offline
Junior Member
 
Join Date: Jul 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Question DNSmasq installed, DNS not resolving

Hello,

I installed DNSmasq.. Then I broke something and had to adjust some settings in my named.conf.options file so that DNSmasq would not return error: "failed to bind".

Details:

auth-nxdomain no; # conform to RFC1035
listen-on { 98.142.210.0/24; }; #attempt to fix dnsmasq
listen-on-v6 { ip6-localhost; };
(from http://tjworld.net/wiki/Linux/DnsMas...ssAlreadyInUse)

So now DNSmasq runs without error, but when I set hosteddomain.tld to ns1.serverdomain.tld and ns2.serverdomain.tld, I get a Page Load Error like the domain isn't resolving. I believe I've done everything I can to configure properly:

1.) Installed DNSmasq per
http://www.howtoforge.com/mydns_mydn...on_ubuntu_edgy
(have double checked all config files)

2.) Setup host summary at GoDaddy per
http://www.howtoforge.com/ispconfig_dns_godaddy

2.) Set up DNS in ISPconfig 3 per screen shots in
http://www.howtoforge.com/forums/showthread.php?t=27030

4.) Setup hosteddomain.tld in 'Sites'.

3.) Now, when I..
dig @ns1.serverdomain.tld any hosteddomain.tld

Returns:

; <<>> DiG 9.5.1-P2 <<>> @ns1.serverdomain.tld any hosteddomain.tld
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 57766
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;hosteddomain.tld. IN ANY

;; Query time: 16 msec
;; SERVER: *serverip*#53(*serverip*)
;; WHEN: Tue Jul 7 22:07:31 2009
;; MSG SIZE rcvd: 37

This appears to not answer? Domain does not resolve. I think I'm out of things to configure, and I believe I've configured everything properly. Should this work or am I off base completely on running DNS in ISPconfig 3?

I know this is strictly DNS related because if I switch to use GD default nameservers the site resolves.

Thanks, I have found all the support here to be incredibly helpful.

Last edited by y87; 7th July 2009 at 21:20. Reason: Typo
Reply With Quote