View Single Post
  #4  
Old 20th March 2006, 13:44
pureblood pureblood is offline
Junior Member
 
Join Date: Mar 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok this hints me to edit the ::scripts with my real directory which is /var/lib/scripts

I edited your script and now i get this
Code:
--13:43:51--  http://www.falkotimme.com/howtos/dedicated_server_backup_restore_systemimager/functions
           => `functions'
Resolving www.falkotimme.com... 81.169.182.36
Connecting to www.falkotimme.com[81.169.182.36]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 34,564 [text/plain]

100%[=================================================================================>] 34,564        --.--K/s

13:43:51 (3.63 MB/s) - `functions' saved [34564/34564]

mv: cannot move `functions' to `/etc/init.d/functions': No such file or directory
/tmp/my_image.master: line 13: /etc/init.d/functions: No such file or directory
btw I also use a strato server but the rescue system does not seem to be busy box .. this maybe a problem right?

ok next thing I now just made an mkdir /etc/init.d/ so your skript can work

but next failure is this

Code:
--13:58:51--  http://www.falkotimme.com/howtos/dedicated_server_backup_restore_systemimager/functions
           => `functions'
Resolving www.falkotimme.com... 81.169.182.36
Connecting to www.falkotimme.com[81.169.182.36]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 34,564 [text/plain]

100%[=================================================================================>] 34,564        --.--K/s

13:58:51 (9.15 MB/s) - `functions' saved [34564/34564]


get_arch
Partitioning /dev/sda...
Old partition table for /dev/sda:
Error: Error opening /dev/sda: No such device or address
parted -s -- /dev/sda mklabel msdos || shellout
Error: Error opening /dev/sda: No such device or address
Killing off running processes.
kill: usage: kill [-s sigspec | -n signum | -sigspec] [pid | job]... or kill -l [sigspec]
udp-receiver: no process killed
rsync: no process killed

write_variables
\s \r \m\ \n
LFS based rescue system
ok this is caused because my image originated from an sda install and the server only has a hda
so I just changed the sda`s with hda`s

but now I ended up here
Code:
: bad interpreter: No such file or directory
I think this is caused by this
Code:
::${IMAGENAME}/
part in the my_image.master
and I am sure it fails for the same reason like the script failed in the first place above where I replaced
::scripts with my real directory which is /var/lib/scripts

but I dont know why this doesnt work out of the box ?
what do the two colons mean?

Last edited by pureblood; 20th March 2006 at 14:34.
Reply With Quote