View Single Post
  #6  
Old 24th June 2009, 20:18
Schnacki Schnacki is offline
Junior Member
 
Join Date: Jun 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Same problem but other "solution"

Quote:
Originally Posted by till View Post
Your suphp configuration files seems to be overwritten or you installed suphp after you installed ispconfig. Please update your ispconfig installation and choose to reconfigure services during update.
I had the same problem discussed in this thread right after fresh install (following the tutorial für Lenny). I could only fix it by setting
Code:
x-httpd-suphp=php:/usr/bin/php-cgi
x-httpd-php=php:/usr/bin/php-cgi
in /etc/suphp/suphp.conf.

Today I updated (via ispconfig_update.sh) to 3.0.1.3 and chose "reconfigure Services". This reset the /etc/suphp/suphp.conf to only enable
Code:
x-httpd-suphp=php:/usr/bin/php-cgi
x-httpd-suphp=php:/usr/bin/php-cgi
(yes, twice). Suphp again only wrote
Code:
[Wed Jun 24 19:52:57 2009] [error] [client 79.229.47.80] SecurityException in Application.cpp:440: Handler not found in configuration
[Wed Jun 24 19:52:57 2009] [error] [client 79.229.47.80] Caused by KeyNotFoundException in Configuration.cpp:234: Handler "x-httpd-php" not found
[Wed Jun 24 19:52:57 2009] [error] [client 79.229.47.80] Premature end of script headers: index.php
to the error-log.

What is the correct content for the /etc/suphp/suphp.conf?
Reply With Quote