View Single Post
  #1  
Old 24th June 2009, 13:02
Mkipz Mkipz is offline
Junior Member
 
Join Date: Jun 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default FFMPEG maybe not an php library?

HI all,

I installed ffmpeg from source versions 0.6.0

When i run make test i get the following output

Quote:
Build complete.
Don't forget to run 'make test'.

PHP Warning: PHP Startup: Invalid library (maybe not a PHP library) 'ffmpeg.so' in Unknown on line 0
PHP Warning: PHP Startup: Invalid library (maybe not a PHP library) 'ffmpeg.so' in Unknown on line 0

Warning: PHP Startup: Invalid library (maybe not a PHP library) 'ffmpeg.so' in Unknown on line 0
PHP Warning: PHP Startup: Invalid library (maybe not a PHP library) 'ffmpeg.so' in Unknown on line 0

Warning: PHP Startup: Invalid library (maybe not a PHP library) 'ffmpeg.so' in Unknown on line 0
PHP Warning: PHP Startup: Invalid library (maybe not a PHP library) 'ffmpeg.so' in Unknown on line 0

Warning: PHP Startup: Invalid library (maybe not a PHP library) 'ffmpeg.so' in Unknown on line 0
PHP Warning: PHP Startup: Invalid library (maybe not a PHP library) 'ffmpeg.so' in Unknown on line 0

Warning: PHP Startup: Invalid library (maybe not a PHP library) 'ffmpeg.so' in Unknown on line 0

================================================== ===================
PHP : /usr/local/bin/php
PHP_SAPI : cli
PHP_VERSION : 5.2.10
ZEND_VERSION: 2.2.0
PHP_OS : Linux - Linux vs04002 2.6.26-2-openvz-686 #1 SMP Thu May 28 17:08:31 UTC 2009 i686
INI actual : /usr/local/Zend/etc/php.ini
More .INIs :
CWD : /usr/local/src/ffmpeg-php-0.6.0
Extra dirs :
VALGRIND : Not used
================================================== ===================
Running selected tests.
FAIL ffmpeg getAudioBitRate test [tests/getAudioBitRate.phpt]
FAIL ffmpeg getAudioChannels test [tests/getAudioChannels.phpt]
FAIL ffmpeg getAudioCodec test [tests/getAudioCodec.phpt]
FAIL ffmpeg getAudioSampleRate test [tests/getAudioSampleRate.phpt]
FAIL ffmpeg getAudioStreamId test [tests/getAudioStreamId.phpt]
FAIL ffmpeg getBitRate test [tests/getBitRate.phpt]
FAIL ffmpeg getDuration test [tests/getDuration.phpt]
FAIL ffmpeg getFileName test [tests/getFileName.phpt]
SKIP ffmpeg getFrame test [tests/getFrame.phpt] reason: ffmpeg extension not loaded
FAIL ffmpeg getFrameCount test [tests/getFrameCount.phpt]
FAIL ffmpeg getFrameHeight test [tests/getFrameHeight.phpt]
FAIL ffmpeg getFrameNumber test [tests/getFrameNumber.phpt]
FAIL ffmpeg getFrameRate test [tests/getFrameRate.phpt]
FAIL ffmpeg getFrameWidth test [tests/getFrameWidth.phpt]
SKIP ffmpeg getFrame backwards test [tests/getFramesBackwards.phpt] reason: ffmpeg extension not loaded
SKIP ffmpeg getFrames forward test [tests/getFramesForward.phpt] reason: ffmpeg extension not loaded
SKIP ffmpeg getFrames forward test [tests/getFramesForwardPassedEnd.phpt] reason: ffmpeg extension not loaded
SKIP ffmpeg getFramesNoArg test [tests/getFramesNoArg.phpt] reason: ffmpeg extension not loaded
FAIL ffmpeg getID3Info() test [tests/getID3Info.phpt]
SKIP ffmpeg get key frames test [tests/getNextKeyFrame.phpt] reason: ffmpeg extension not loaded
SKIP ffmpeg getPTS test (Fixme: This test is no good with robot.avi) [tests/getPTS.phpt] reason: ffmpeg extension not loaded
FAIL ffmpeg getPixelAspectRatio test [tests/getPixelAspectRatio.phpt]
FAIL ffmpeg getPixelFormat test [tests/getPixelFormat.phpt]
FAIL ffmpeg getVideoBitRate test [tests/getVideoBitRate.phpt]
FAIL ffmpeg getVideoCodec test [tests/getVideoCodec.phpt]
FAIL ffmpeg getVideoStreamId test [tests/getVideoStreamId.phpt]
FAIL ffmpeg hasAudio test [tests/hasAudio.phpt]
SKIP ffmpeg test key frame [tests/isKeyFrame.phpt] reason: ffmpeg extension not loaded
FAIL ffmpeg persistent movie test [tests/persistentMovie.phpt]
================================================== ===================
Number of tests : 29 21
Tests skipped : 8 ( 27.6%) --------
Tests warned : 0 ( 0.0%) ( 0.0%)
Tests failed : 21 ( 72.4%) (100.0%)
Expected fail : 0 ( 0.0%) ( 0.0%)
Tests passed : 0 ( 0.0%) ( 0.0%)
---------------------------------------------------------------------
Time taken : 2 seconds
================================================== ===================

================================================== ===================
FAILED TEST SUMMARY
---------------------------------------------------------------------
ffmpeg getAudioBitRate test [tests/getAudioBitRate.phpt]
ffmpeg getAudioChannels test [tests/getAudioChannels.phpt]
ffmpeg getAudioCodec test [tests/getAudioCodec.phpt]
ffmpeg getAudioSampleRate test [tests/getAudioSampleRate.phpt]
ffmpeg getAudioStreamId test [tests/getAudioStreamId.phpt]
ffmpeg getBitRate test [tests/getBitRate.phpt]
ffmpeg getDuration test [tests/getDuration.phpt]
ffmpeg getFileName test [tests/getFileName.phpt]
ffmpeg getFrameCount test [tests/getFrameCount.phpt]
ffmpeg getFrameHeight test [tests/getFrameHeight.phpt]
ffmpeg getFrameNumber test [tests/getFrameNumber.phpt]
ffmpeg getFrameRate test [tests/getFrameRate.phpt]
ffmpeg getFrameWidth test [tests/getFrameWidth.phpt]
ffmpeg getID3Info() test [tests/getID3Info.phpt]
ffmpeg getPixelAspectRatio test [tests/getPixelAspectRatio.phpt]
ffmpeg getPixelFormat test [tests/getPixelFormat.phpt]
ffmpeg getVideoBitRate test [tests/getVideoBitRate.phpt]
ffmpeg getVideoCodec test [tests/getVideoCodec.phpt]
ffmpeg getVideoStreamId test [tests/getVideoStreamId.phpt]
ffmpeg hasAudio test [tests/hasAudio.phpt]
ffmpeg persistent movie test [tests/persistentMovie.phpt]
================================================== ===================
As you can see he won't load the ffmpeg.so because it isn't an php library? after some days of searching on google i didn't get any result on how to fix this!

Any one got aan solution for this?

Greetings,
Dion
Reply With Quote
Sponsored Links