View Single Post
Old 24th June 2009, 07:42
danielborene danielborene is offline
Junior Member
Join Date: Jun 2009
Posts: 24
Thanks: 7
Thanked 2 Times in 1 Post

I Finnaly found out what was wrong with it...
My server is based on this howto:
The Perfect Server - Ubuntu 9.04 [ISPConfig 3]

I don't know why, but all the information I found online to make pure-ftpd work with fail2ban tells to read log /var/log/auth.log I dont know if other distributions uses auth.log... but after analyzing /etc/fail2ban/filter.d/pure-ftpd.conf and log files... auth.log is not the right file.. I switch to /var/log/messages
its working now..
so my jail.local pure-ftpd looks like this..

enabled = true
port = ftp
filter = pure-ftpd
logpath = /var/log/messages
maxretry = 3

Also had to enable DontResolve to get IP only no DNS, under /etc/pure-ftpd/conf/
Create a file called DontResolve, edit it, and type yes on the first line.

Thanks fot all you help Till.
Reply With Quote