View Single Post
  #1  
Old 19th March 2006, 06:09
Chaoticmass Chaoticmass is offline
Junior Member
 
Join Date: Mar 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Question Quota on JFS raid1 problem- cant find filesystem

I'm posting this as a last resort. I've searched for and found people with similar problems but thier solutions did not work for me. I'm wondering if quota is not working due to the fact that I'm trying it on a software raid1 device or because the filesystem is JFS or a combination of other factors.

Operating system is Debian Sarge. Kernel 2.4.27-2-k7

Here's /etc/fstab:

Code:
[root@Dauntless] /etc #cat fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda1       /               ext3    defaults,errors=remount-ro 0       1
/dev/md0        /var            jfs     defaults,usrquota        0       2
/dev/hda5       none            swap    sw              0       0
/dev/hdb        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
[root@Dauntless] /etc #
/etc/mtab

Code:
[root@Dauntless] /etc #cat mtab
/dev/hda1 / ext3 rw,errors=remount-ro 0 0
proc /proc proc rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs rw 0 0
/dev/md0 /var jfs rw,usrquota 0 0
usbfs /proc/bus/usb usbfs rw 0 0
And here is /etc/modules

Code:
[root@Dauntless] /etc #cat modules
ide-cd
ide-detect
ide-disk
psmouse
quota_v2
Trying to get user quotas setup on /dev/md0, which is mounted to /var. I've touched a aquota.user file and chmodded it 600. I've remounted, rebooted, etc..

Still when I try to run quotacheck it always gives me errors, saying it cant find any filesystems mounted with quota option.

Code:
[root@Dauntless] /var #quotacheck -vaum
quotacheck: Can't find filesystem to check or filesystem not mounted with quota option.
What am I missing? I had quota running fine on this machine when I only had one HD. Now I've gone to a software raid configuration (webroot needed bigger hard drives and some mirrored raid redundancy) with JFS (wanted to try it out, seems to be the best all-around FS with journaling and low CPU usage) and after reinstalling debian fresh I cant get quota to work.
Reply With Quote
Sponsored Links