View Single Post
  #1  
Old 20th June 2009, 03:33
Bebop17 Bebop17 is offline
Junior Member
 
Join Date: Apr 2008
Posts: 15
Thanks: 5
Thanked 0 Times in 0 Posts
Question Upgraded ISPConfig 2 can't see content

I just upgraded ISPConfig from 2.x to 2.2.32. At the same time, I changed the hostname (and NS domains). It took several tries but it is working almost fine now. It was originally set up using the Perfect Server How-To. OS is Centos 5.3, on a server with 2 IPS serving as NS1 and NS2.

It is working fine except that no resellers, clients or sites are showing up in ISPConfig. The sites are still there in /var/www, I can access them (via IP) by FTP, I can get into their databases via phpMyAdmin - I just can't see them in ISPConfig. And of course their DNS records all need to be updated with the new domain for server and NS.

Yes, I deleted /root/ispconfig to redo the upgrade. No, there is no backup in /tmp.

My question is what is the best way to get everything sorted out to keep ISPConfig happy? To get the clients, sites etc. showing in ISPConfig, the DNS records fixed, not sure what else - virtualhost stuff maybe. Should I do it all manually or leave some of it to be done from within ISPConfig afterward?

And I'm curious - I actually have very few sites, and none that I couldn't easily recreate - what would be involved in changing over to ISPConfig 3 from this setup? I understand there is no upgrade path. I think I would need to uninstall ISPConfig 2, and replace (my lovely chrooted) BIND with MyDNS. What else would I have to do?
Reply With Quote
Sponsored Links