View Single Post
  #3  
Old 19th June 2009, 11:30
tom tom is offline
Senior Member
 
Join Date: Apr 2006
Posts: 492
Thanks: 8
Thanked 8 Times in 7 Posts
Default

I've tried this:

Quote:
vi pure-ftpd-1.0.21/debian/rules

line 12 add --without-capabilities

optflags=--with-everything --with-largefile --with-pam --with-privsep --with-tls --without-capabilities


then build your .deb package and install dpkg -i pure-ftpd-mysql_1.0.21-8_i386.deb
But still the same:
FTP-Server: Offline

The start now looks like this (without -A -b)
h1609812:~# /etc/init.d/pure-ftpd-mysql start
Quote:
Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -O clf:/var/log/pure-ftpd/transfer.log -u 1000 -E -B
And syslog shows
Quote:
Jun 19 10:36:10 server2 pure-ftpd: (?@?) [ERROR] Unable to switch capabilities : Operation not permitted
The package is build as shown:

Code:
cd /tmp/pure-ftpd-1.0.21/
vi debian/rules (add --without-capabilities)
apt-get build-dep pure-ftpd
apt-get -b source pure-ftpd

Last edited by tom; 19th June 2009 at 12:06.
Reply With Quote