View Single Post
  #4  
Old 16th June 2009, 01:15
simmo simmo is offline
Junior Member
 
Join Date: Jun 2009
Posts: 4
Thanks: 0
Thanked 4 Times in 1 Post
Default

I've finally found what the problem was, and it was the removal of amavis after all.

In master.cf the amavis configuration section includes this settings:

Code:
receive_override_options=no_unknown_recipient_checks, no_header_body_checks
In main.cf there is this line:

Code:
receive_override_options = no_address_mappings
Since I removed the amavis section from master.cf and the content filter line from main.cf the receive_override_options = no_address_mappings setting is preventing the forwarded/catchall addresses from being rewritten. To fix this problem I simply had to change the setting in my main.cf to this:

Code:
receive_override_options=no_unknown_recipient_checks
Reply With Quote