View Single Post
  #2  
Old 9th June 2009, 17:01
Falrish Falrish is offline
Junior Member
 
Join Date: May 2009
Location: Canada
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Falrish Send a message via MSN to Falrish Send a message via Yahoo to Falrish
Default

there are a few places you need to check...

First look in the bind named.conf file for how your ISPConfig is storing the Bind data. Here will will find something like this. (mine is located at /var/named/chroot/var/named/)
Code:
$TTL        86400
@       IN      SOA     ns1.yourdomain.com. admin.yourdomain.com. (
                        2009010101       ; serial, todays date + todays serial #
                        28800              ; refresh, seconds
                        7200              ; retry, seconds
                        604800              ; expire, seconds
                        86400 )            ; minimum, seconds
;
          NS      ns1.yourdomain.com.              ; Inet Address of name server 1
          NS      ns2.yourdomain.com.              ; Inet Address of name server 2
;
  MX      10 s1.yourdomain.com.
erikwestlake.com.      A        127.0.0.1
www       A       127.0.0.1
yourdomain.com.       TXT  "v=spf1 a mx ptr ~all"
;;;; MAKE MANUAL ENTRIES BELOW THIS LINE! ;;;;
ensure you have the www A record (or you could make it a CNAME if you like)

Next check the Apache configuration files. (mine is /etc/apache/vhosts/)
Code:
######################################
# Vhost: www.yourdomain.com:80
######################################
#
#
<VirtualHost 127.0.0.1:80>
SuexecUserGroup nobody web1
ServerName www.yourdomain.com:80
ServerAdmin webmaster@yourdomain.com
DocumentRoot /var/www/web1/web
ServerAlias yourdomain.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
Alias  /cgi-bin/ /var/www/web1/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /var/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
php_admin_flag safe_mode Off
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
AddType text/vnd.wap.wml .wml
AddType text/vnd.wap.wmlscript .ws .wmlscript
AddType image/vnd.wap.wbmp .wbmp
Alias /error/ "/var/www/web1/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
<IfModule mod_rewrite.c>
  RewriteEngine on
  RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
  RewriteRule .* - [F]
</IfModule>
</VirtualHost>
If you have all this up as it is, reload apache and named and you should be good. Let me know if this helps.
Reply With Quote