View Single Post
  #6  
Old 27th May 2009, 20:27
baskin baskin is offline
Senior Member
 
Join Date: Jan 2008
Location: Syros, Greece
Posts: 118
Thanks: 9
Thanked 8 Times in 8 Posts
Default

After the latest update (3.0.1.3) my vhost configuration is:

Quote:
<Directory /srv/www/cywn.gr>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost *:80>
DocumentRoot /srv/www/cywn.gr/web

ServerName cywn.gr
ServerAdmin webmaster@cywn.gr

ErrorLog /var/log/ispconfig/httpd/cywn.gr/error.log

Alias /error/ "/srv/www/cywn.gr/error/"

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /srv/www/cywn.gr/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>
<Directory /srv/www/clients/client2/web4/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>

# cgi enabled
<Directory /srv/www/clients/client2/web4/cgi-bin>
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ /srv/www/clients/client2/web4/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
# suexec enabled
SuexecUserGroup web4 client2
# php as fast-cgi enabled
<Directory /srv/www/cywn.gr/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /srv/www/php-fcgi-scripts/web4/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride all
Order allow,deny
Allow from all
</Directory>

</VirtualHost>
I have also tried to change all

Quote:
AllowOverride Indexes AuthConfig Limit FileInfo
to

Quote:
AllowOverride All
with no luck.

I have also checked that ipplan is working when i moved it to a test server without ispconfig and vhosts (just one site).
Reply With Quote