View Single Post
  #1  
Old 20th May 2009, 01:46
0x1a4 0x1a4 is offline
Junior Member
 
Join Date: May 2009
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default ISP Config email issue

Hey all,

I seem to be having a problem figuring this one out. I did a fresh install of Fedora 10 using the perfect server guide, and then installed ISPConfig. I can get to the web site to configure a virtual domain, and have set up a domain, and an email account. But no matter what I do, I cannot get it to work. I get these errors in /var/log/secure:

Code:
May 19 16:30:10 localhost dovecot-auth: pam_unix(dovecot:auth): check pass; user unknown
May 19 16:30:10 localhost dovecot-auth: pam_unix(dovecot:auth): authentication failure; logname= uid=0 euid=0 tty=dovecot ruser=xxxx@xxxx.com rhost=xxx.xxx.xxx.xxx
May 19 16:30:10 localhost dovecot-auth: pam_succeed_if(dovecot:auth): error retrieving information about user xxxx@xxxx.com
From reading the forum I have tried modifying /etc/pam.d/smtp
Code:
#%PAM-1.0
#auth       include     system-auth
#account    include     system-auth
auth    required   pam_mysql.so user=ispconfig passwd=xxxxx host=127.0.0.1 db=dbispconfig table=mail_users usercolumn=email passwdcolumn=password crypt=1
account sufficient pam_mysql.so user=ispconfig passwd=xxxxx host=127.0.0.1 db=dbispconfig table=mail_users usercolumn=email passwdcolumn=password crypt=1
I have changed /usr/lib64/sasl2/smtp.conf

Code:
#pwcheck_method: saslauthd
#mech_list: plain login
pwcheck_method: authdaemond
log_level: 3
mech_list: PLAIN LOGIN
#authdaemond_path:/var/spool/authdaemon/socket
BTW, I do not have a /var/spool/authdaemon

Here is /etc/postfix/main.cf
Code:
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
mail_owner = postfix
inet_interfaces = all
mydestination = $myhostname, localhost.$mydomain, localhost
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
debug_peer_level = 2
debugger_command =
         PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
         ddd $daemon_directory/$process_name $process_id & sleep 5

sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.5.5/samples

readme_directory = /usr/share/doc/postfix-2.5.5/README_FILES
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
mynetworks = 127.0.0.0/8
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
myhostname = localhost
home_mailbox = Maildir/
mailbox_command =
#virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domains.cf
#virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailboxes.cf
relayhost =
mailbox_size_limit = 0
message_size_limit = 0
I have tried with and without the virtual_mailbox lines.


I am at a loss. It looks like it's simply not looking into the mysql database for users. Anyone have any thoughts?

-J.R.

EDIT:
I cannot log into squirrelmail, POP or IMAP. I have tried web1_user web1_user@domain.com user and user@domain.com in all cases.

Last edited by 0x1a4; 20th May 2009 at 01:53.
Reply With Quote
Sponsored Links