Thread: x84_64
View Single Post
  #13  
Old 28th August 2005, 17:09
gbjbaanb gbjbaanb is offline
Junior Member
 
Join Date: Aug 2005
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi. I have this too: I'm running CentOS 4.1, 64-bit.

The first error I got was unable to link with libmysqlclient. I think I fixed this by installing mysql-devel but I may also have edited the lib path to /usr/lib64 as well. I can't remember so I'll have to report back on this when I next install on a clean system.

The second error:
Code:
/root/ispconfig/openssl/lib/libssl.a(s2_srvr.o): relocation R_X86_64_32S against `ssl2_accept' can not be used when making a shared object; recompile with -fPIC
was solved by removing reference to the ISPConfig-supplied openssl. This may be an issue with the compile options for the ispconfig-supplied openssl, but if openssl is supplied with the distro, I see no need to recompile it.

Either way, 'srg' got it right by editing compile_aps/compile and changing the PHP directive "--with-openssl=$(INSTALL_ROOT)/openssl" to "--with-openssl"
I do have openssl-devel installed in case you need this.
Reply With Quote