View Single Post
  #4  
Old 8th May 2009, 11:26
maikcat maikcat is offline
Junior Member
 
Join Date: May 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

you must have something inside main.cf like this:

mynetworks = 192.168.1.0/24 <--your local net
fallback_relay =
mydestination = test.gr
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_authenticated-header = yes
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions =
permit_sasl_authenticated,
permit_mynetworks,
reject_unauth_destination

the above are for authanticating users to enable to relay mail through
your server.

try this to check your mail server
telnet ip 25

you will get smtp banner like

220 Esmtp service

then type

ehlo localhost.localdomain

you should get something like

250-PIPELINING
250-SIZE 15000000
250-ETRN
250-AUTH PLAIN LOGIN <--this means that your sever can authenticate clients to allow them to relay
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN

if there is not the above line ,means that your server allows relay based
on ip address origin only.
check main.cf... (my networks setting..)

have a nice day

michael

ps: if you want to enable auth to work you MUST start saslauthd service as well..
Reply With Quote