View Single Post
  #1  
Old 30th April 2009, 10:48
brandoni brandoni is offline
Junior Member
 
Join Date: Apr 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Red face messed up my ISPC3 installation

I've been working on my new system for a couple of weeks now and it seemed almost ready to go into production, until... I dropped squirrelmail and roundcube in favor of the egroupware package. After this the ISPConfig control panel wouldn't load right anymore- the page only displayed the title but no content.

For whatever reason I thought it would be a good idea to change the ispconfig user password in mysql... well now nothing works The first thing I need to work on now is IMAP.

rather that reinstalling again, i want to understand how to fix it. I tried putting the new password into every affected file in both encrypted form and plain text (which way is correct anyways?) but still get this error:

Quote:
authdaemond: failed to connect to mysql server (server=127.0.0.1, userid=ispconfig): Access denied for user 'ispconfig'@'localhost' (using password: YES)
I can log into mysql using this account and password. I've even tried giving this mysql account complete access to everything.

the files I changed were:
/etc/postfix/mysql-virtual_*.cf
/etc/courier/authmysqlrc
/usr/local/ispconfig/interface/lib/config.inc.php
/usr/local/ispconfig/server/lib/config.inc.php

I would be so grateful for some help or a hint
Reply With Quote
Sponsored Links