View Single Post
  #1  
Old 27th April 2009, 03:13
dpicella dpicella is offline
Senior Member
 
Join Date: Apr 2009
Posts: 116
Thanks: 9
Thanked 8 Times in 7 Posts
Default New Install mod_ssl won't listen on port 443

I just installed ISPConfig 3 and I can't get mod_ssl to listen on port 443

As far as I can tell Apache should listen to my VirtualHost directives on port 443.

I'm getting "failure to connect"

I have a dedicated IP and the csr and key files are in place. It should work. I've restarted the server and rebooted the machine. Here is the apache config section for the domain.

Code:
<IfModule mod_ssl.c>
###########################################################
# SSL Vhost
###########################################################

<VirtualHost 208.166.54.19:443>
      DocumentRoot /var/www/majella.us/web

    ServerName majella.us
    ServerAdmin webmaster@majella.us

    ErrorLog /var/log/ispconfig/httpd/majella.us/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    SSLEngine on
    SSLCertificateFile /var/www/clients/client1/web2/ssl/majella.us.crt
    SSLCertificateKeyFile /var/www/clients/client1/web2/ssl/majella.us.key

        <Directory /var/www/majella.us/web>
        Options FollowSymLinks
        AllowOverride Indexes AuthConfig Limit
        Order allow,deny
        Allow from all

        # ssi enabled
        AddType text/html .shtml
        AddOutputFilter INCLUDES .shtml
        Options +Includes
    </Directory>
    <Directory /var/www/clients/client1/web2/web>
        Options FollowSymLinks
        AllowOverride Indexes AuthConfig Limit
        Order allow,deny
        Allow from all

        # ssi enabled
        AddType text/html .shtml
        AddOutputFilter INCLUDES .shtml
        Options +Includes
    </Directory>

    # cgi enabled
        <Directory /var/www/clients/client1/web2/cgi-bin>
      Order allow,deny
      Allow from all
    </Directory>
    ScriptAlias  /cgi-bin/ /var/www/clients/client1/web2/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    # mod_php enabled
    AddType application/x-httpd-php .php .php3 .php4 .php5
        php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@majella.us"
    php_admin_value upload_tmp_dir /var/www/clients/client1/web2/tmp
    php_admin_value session.save_path /var/www/clients/client1/web2/tmp
    #php_admin_value open_basedir /var/www/clients/client1/web2:/usr/share/php5


</VirtualHost>
</IfModule>
Reply With Quote
Sponsored Links