Thread: Apache problem
View Single Post
  #3  
Old 23rd April 2009, 13:40
Cracklefish Cracklefish is offline
Member
 
Join Date: Mar 2009
Posts: 95
Thanks: 8
Thanked 3 Times in 3 Posts
Smile I've finally got it to work...

No but thanks for the tip about apache2ctl. It has saved me from slashing my wrists as I'd run out of hair to tear out.

Revitalised for another days hacking I think I have now managed to get it to work but I had to make some changes.

I have added another vhost file in sites available and a symlink to it in sites enabled.

I get no error messages from apache2 or apache2ctl, I can access ispconfig, phpmyadmin and squirrelmail and all the websites I create.

I have also put an index file in srv/www/htdocs just for the hell of it. I'll take it out if somebody gives me a good reason.

Code:
NameVirtualHost *:80

<VirtualHost _default_:80>
    DocumentRoot /srv/www/htdocs
  
    ServerName golf1.greenway.co.uk
    ServerAdmin webmaster@localhost

    <Directory /srv/www/golf1.greenway.co.uk>
        Options FollowSymLinks
        AllowOverride Indexes AuthConfig Limit
        Order allow,deny
        Allow from all
        <Files ~ '.php[s3-6]{0,1}$'>
            Order allow,deny
            Deny from all
            Allow from none
        </Files>
    </Directory>
    
</VirtualHost>
Incidentally, I don't know if this is significant but the <!--ADDRESS//--> and <!--SUPPORT//--> tags in index.html don't work.

Perhaps somebody could tell me if this is a bodge a bugfix or have I just added something that got lost!
Reply With Quote