View Single Post
  #1  
Old 27th August 2005, 16:40
skeeta skeeta is offline
Junior Member
 
Join Date: Aug 2005
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Red face Totally Confused DNS!

I ran the "perfect" setup for Fedora 4 & installed ISPConfig following the instructions to the letter (I previously did both but messed it up so I reformatted and reinstalled everything - Quicker in the long run for me).

I have only one publically available Static IP (ADSL modem/router) and a 4 port hub. My network is setup using static 192.168.1.xxx ips and my DNS server is authorative for my domain and is located on my 192.168.1.xxx network. The server is named "www" with A records for "mail", "ftp", "ns1" & "ns2" (yeah I know I should do that). From within my network I can ping all fqdn's.

Problem:
I can now no longer send or receive e-mails and my webpage is not accessible outside of my local network (these I have using my primary/secondary dns).

When I try to send email within my network I get "Host or domain name not found. Name service error for name=mail.mydomainname.com.au type=A: Host found but no data record of requested type"

When I try to send externally (using Hotmail for testing) I get "Unable to deliver message to the following recipients, due to being unable to
connect successfully to the destination mail server."

Using www.dnsstuff.com to perform various checks portions of the report state

1) "Error: At least one of your MX records points to an IP address that is not a public IP. The problem IP(s) are:

192.168.1.103 is not a public IP
Note that these IPs are not reachable, which can cause extra resource usage, slight mail delays, and possibly bounced mail."

2) Error: At least one of your WWW IPs is not a public IP. The problem IP(s) are:

192.168.1.102 is not a public IP
That means that some or all people trying to get to your web site will not be able to get there.

I have manually tried to correct these dns entries but seem to be getting nowhere.

WHAT HAVE I DONE WRONG?

Your help will be gladly received
Reply With Quote
Sponsored Links